Attempts to share a link to a community topic via email send me to a pop up: "Do you want to open Chrome?"

Description of the issue:
When I attempt to share a link to a community topic via email by using the provided email icon under the chain link icon following a post, I receive a pop up asking if I want to open Chrome instead of sending me to my email.
How can this issue be reproduced?

  1. Go to the bottom of any post.
  2. Click the chain link to the right of the heart, labeled “share a link to this post”
  3. Click the orange envelope icon labeled “send this link in an email”

Expected result:
I expected the link would either forward to the email listed in my profile, or copy a link to the topic to my clipboard that I can paste in my email manually.
Brave Version( check About Brave):
Version 0.69.132 Chromium: 77.0.3865.90 (Official Build) (64-bit)
Additional Information:
Running on macOS 10.14.6. How should this share link function?
thank you

@Tired_of_Accounts,
Do you have Brave set as your default web browser? Additionally, do you have you preferred email client set in Settings --> Privacy/security --> Site Settings --> Handlers?

1 Like

Brave set as default web browser: Yes
Preferred email client set in above settings path: No, however, “Allow sites to ask to become default handlers for protocols (recommended)” is selected.
Do you have other suggestions? I would like to be able to share community topics/threads with colleagues outside the community using the email in my profile however it seems to be defaulting to gmail. I don’t know why this connection exists. I do have the Chrome browser loaded on my machine, primarily for page translation since I work internationally. I appreciate your help.

@Tired_of_Accounts,
If you visit your preferred email account in-browser, are you prompted to save the client as a default handler by the browser? If not prompted, do you see the Default handler icon in the address bar: image

@Mattches. That did the trick! Thanks. When I visited my preferred email account in browser, Brave did prompt me to make that account my default handler. Once selected, I confirmed that the email account had been added here: chrome://settings/handlers. So I was able to share a Brave topic via my preferred email. As far as I can tell, no other email account was ever set to default. Is it possible that if no email default is set, the chromium-based code launches chrome and any email address associated?

Also of note, when I navigated to the settings path I mentioned in Brave, the URL shows up as: “brave://settings/handlers”, however when I pasted it into this comment, it was changed to: “chrome://settings/handlers.” Any idea why?
Thank you for the help.

1 Like

You may have Chrome set to be the default browser for email links on the system level, which would explain why email links would open in the Chrome browser.

Nice catch :slight_smile:
The Brave portion is actually a cosmetic patch rather than a change in the actual text. Its only temporary and we plan to have a more permanent solution soon.