Android : no possible to update (for sync)

Hi,
I’m using Brave on Android One Plus 5 (Android 10).
I would tosynchronize Tabs and bookmarks with new phone. When I try to update the old one, systems says : “impossible to update, your version is too old, please update before”.

But the update doesn’t works.
how can I do that properly?

Many thanks

Hi @bravami

Thanks for bringing this to our attention and I’m sorry to hear you are going through this. Could you please try installing the Beta or Nightly version of Brave to see if the issue persist on those versions?

Let us know if that works!