Always have to sign in to facebook from a link in gmail

**Description of the issue:**BRAVE always requests sign in credentials when clicking on a facebook link in gmail. Everytime!!
How can this issue be reproduced?

  1. I get notifications from facebook in my Social tab in gmail account.
  2. When I click on “view post” button in the email, it opens a facebook tab and asks me to “sign in”.
  3. I supply my credentials and it takes me to facebook post linked in gmail.

Expected result: I would like to be taken directly to my facebook page without having to sign in from my gmail notification. Chrome browser allows this.

Brave Version( check About Brave): [Version 1.8.96 Chromium: 81.0.4044.138 (Official Build) (64-bit)]
**Additional Information:**If I click on my bookmark for facebook, in BRAVE, I am taken directly to facebook. My credentials have been saved in BRAVE passwords. Its just the link from gmail to facebook where BRAVE is not working properly.

Hi @labud,
For Facebook, are you using the default Shield settings or do you have all cookies allowed enabled?

I have “only block cross-site cookies” and Facebook logins and Google logins are set to be allowed.
That is in BRAVE settings.

The link should open Facebook without asking you to sign in, can you try creating a new profile and seeing if the issue persists? Click on the menu icon in the top right corner > create a new profile.


I have created a new profile and set up the necessary bookmarks and saved the passwords.
It does seem to be working now.
I will continue to monitor it and see how it goes.
How do I delete the other profile?

Thank You

My suggestion was to test a new profile, I did not mean for you to migrate to the new profile, apologies.
Creating a new profile is to test whether or not the issue is browser or profile related. If you still want to to troubleshoot your main profile you can try disabling all of your extensions. If that solves the problem, the next steps would be to enable each extension one by one, and seeing which one causes the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.