400 Bad Request (but site works on other browsers)

When I try to pull up a client’s website, I get a 400 Bad Request error.

"Bad Request
Your browser sent a request that this server could not understand.
Size of a request header field exceeds server limit.

Additionally, a 400 Bad Request error was encountered while trying to use an ErrorDocument to handle the request."

The URL is: https://protekpainters.com

Shields were down/off. I’ve worked with this website for years without issue. It’s a new problem. I (and others) can pull the site up fine on other browsers including Firefox, Chrome, and Edge.

Brave version 1.39.111


Using Brave Browser for Mac, version 1.39.111 . . .

Using Brave Browser > New Private Window . . .

Using site-specific Shields (Lion icon) panel . . .

Screen Shot 2022-06-08 at 1.22.53 AM

Allowed javascripts for:

  • protekpainters.com
  • cdn-dkjhk.nitrocdn.com

Does not appear to be a problem:

Looking at the site https://protekpainters.com/ seems fine with default shields, (not blocking scripts/or changing other shield settings) Could also be affect by any VPN software if that’s being used.

Does the latest Version 1.39.120 update on Brave help?

Thank you for trying to help. It turns out that I just needed to clear the browser history “for all time” versus recent history. Here’s the article that helped me fix it, in case other people have this issue. The thing that worked for me is in the “Clear Browser Cache and Cookies” section, but there were other suggestions if that doesn’t work.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.