Twitter does not load if shield is up. Same in private mode

Description of the issue:
Twitter does not load if shield is up. Same in private mode.
Same problem as this OP:

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no)

Does the site function as expected when Shields are turned off?

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
I tried turning off everything and Twitter still doesn’t load. I have to turn shield off completely to get it to load.

Does the site work as expected when using Chrome?
No idea.

Brave version (check About Brave):
Version 1.5.112 Chromium: 80.0.3987.132 (Official Build) (64-bit)

Hi @kg3, welcome to Community!

Can you try creating a new profile and then revisiting twitter?

Thank you, it works now, what did I do wrong before?

If twitter works in a new profile, that means there is something with your main profile that is preventing twitter from loading. We’ll have to go through some steps to rest things.

Can you go to twitter and make sure your Shield settings matches mine in this picture:

Enter this link to your address bar:
then click on clear data and reset permissions

Revisit twitter and let me know if things load properly. If it’s not loading properly you might have an extension causing the issue, you can try disabling them to see if twitter will load.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.