Playlist not loading next song


Playlist is lifesaving. But with the new release when one song ends the next doesn’t start. And oddly enough it was working in the previous release if you go to YouTube website play a video and then go to playlist.

How can this issue be reproduced?

  1. open playlist
  2. Wait for the song to finish
  3. The next song doesn’t start

The expected result is that you don’t need to open YouTube website to make the playlist work well or actually making it work at all.

**Brave Version 1.48.1

iPhone 12 iOS 16.3.1

Additional Information:


I have been facing the same issue for some time. Playlist is one of my favourite features on Brave Browser but it has become more of a hinderance than a help recently. I started facing the issue a few updates ago and have since been waiting to see if any update fixed this bug but unfortunately not. I have tried everything bar deleting and re-installing the app which I would hate to do.

This also affects the PiP feature or background audio being used on Brave as my video/audio will freeze and I will need to fiddle around to get it to play again (refresh the page, press play/pause a few times or see if the file appears in the control centre as playing and fiddle with that too)

I have deleted files from playlist I dont use/listen to often removed the offline data to see if that would work, tried moving files to a new folder, restarting my phone but no luck. The only way Playlist will move forward after the track has ended is if I toggle the repeat 1 track button on but to play the next track in the album/folder automatically is impossible. It will skip to the next track only to freeze and I have to press play myself. I have the latest version of the app as well as the latest IOS installed.

Do you have autoplay enabled in the playlist settings?

Yes, all the settings that I would need for this to be working are on but I am still facing this problem.

Hello @Hectorricardus

Thank you for reaching us and I’m sorry to hear you are going through this. Could you kindly use private mode to see if the issue persist?

In order to get a Private window, you’d have to hit the tabs button (like you’re trying to switch tabs, it’s a little box with a number showing how many tabs open). Then while it’s showing all open tabs, you’ll see the Private button to click on.

Let us know if that helps!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.