Playlist Auto-Play setting is not working (it will always auto-play regardless)

Description of the issue:

Tested with YouTube videos, whether Auto-Play is enabled or disabled in the settings, the videos will always auto-play when the browser is opened and then the Playlist is opened.

How can this issue be reproduced?

  1. Make sure Auto-Play is turned off in the Playlist settings
  2. Add a YouTube vide to Playlist
  3. Close the browser.
  4. Open the browser.
  5. Go to Playlist and the video will auto-play

Expected result:

For Playlist to not auto-play videos when opening.

Brave Version( check About Brave):

Version 1.34.1 (22.1.20.22)

Mobile Device details

Apple iPad mini (5th generation) with iOS 15.3

@Go-go_duck ,

Might you help “fred1”, here?

I do not use Playlist nor Auto-Play (meaning, it is always OFF)

Auto-Play - iOS setting on iPhone is:

Settings > Playlist > Auto-Play (there, is an ON / OFF switch)

No Permissions feature / settings

No Extensions feature

There is a “Private Browsing Only” switch:

Settings > Brave Shields & Privacy > OTHER PRIVACY SETTINGS > Private Browsing Only (ON / OFF switch)

@fred1 is using an iPad, and it has different real estate (I imagine); so, his Brave Browser settings are likely to have more features.

My apologies, @Go-go_duck , for bothering you with this iOS issue.

1 Like

Hey :slight_smile: I’m really not sure that I can, since I don’t know Brave for iOS, but I’ll give it a try.

Firstly, just to make sure we are talking about the same Autoplay function, can you check that Autoplay is set to Blocked under SettingsSecurity & PrivacySites & Shields SettingsPermissionsAdditional Permissions (i.e. brave://settings/content/autoplay)?

Assuming that is the case, could you disable any extensions that you may have installed, just in case they are overriding your browser settings? Alternatively, you could test this with a fresh Brave profile (again setting Autoplay to Blocked there), or with a Private window (if you don’t allow extensions in Private).

fred1,

At first, the issue seemed to me, at least, to be something that your Brave Browser settings might resolve.

Because I am not a regular video observer, I thought that @Go-go_duck (who seems to know about video), might be able to help you.

But now, unless you can fix the issue by using the Brave Browser for iOS “Clear Data Now” function . . . followed by quitting everything on your iPad and performing a full Restart as recommended by Apple:

https://support.apple.com/guide/ipad/force-restart-ipad-ipad9955c007/ipados

. . . then you have indeed discovered a bug, and possibly @Mattches (Brave Support) can help.

Brave Browser issue at GitHub - Sept. 26, 2021:

Brave Browser issue at GitHub - Feb. 19, 2021

Looks like I can reproduce this issue as well. I’ve reached out to our iOS team about the issue to see if it’s known. If not I will open an issue on our Github for tracking.

1 Like

I’ve opened the following issue:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.