Mac OS 10.14.6 and latest Brave browser

I’ve used Brave for 2+ years and tonight it crashed every time it was started. I deleted the old app and downloaded the latest, installed it and now it’s saying

"You can’t use this version of the application “Brave Browser.app” with this version of macOS.

You have macOS 10.14.6. The application requires macOS 10.11 or later"

Did it lose the ability to count?

Anyone else run into this? / thx

I’m back… it’s fixed. There were apparently a couple PID’s that were not cancelled when it was last closed and all that had to be done was to get rid of those processes. Both the old and the new one work fine.