Instalador do bave

olá, descobri a pouco tempo este incrível navegador, leve, seguro e com todas as ferramentas que preciso. Durante o uso houve uma falha no mesmo o qual precisou ser encerrado, após abrir, 2 min após abri-lo, o erro aparecia e precisava ser reiniciado, decidir desinstalar e instalar novamente para corrigir o problema, mas não obtive sucesso.

Aparecia a mensagem a baixo
brava

vi unico topico diponivel para instalar o brave beta e o brave nightly.

Ambos foram testados e apresentavam a mesma mensagem do foto, poderiam me ajudar a resolver?

obs: sistema operacional windows 8.1

Esse é o seu problema. Ele não é mais um sistema operacional suportado. Portanto, se você tentar fazer o download na página principal de download, ele não será instalado. Você precisará instalar a versão mais antiga do Github.