I am suddenly getting ads on YouTube as if I wasn't using Brave

Description of the issue:
As of yesterday when using Brave I started to see ads appear on youtube when I have been using Brave for months and haven’t seen a single one prior. I didn’t change any of the settings I tried multiple things such as clearing cookies and reinstalling Brave but neither worked.

Exact URL of the website in question:
It happens on any youtube video that would typically show adds

Screenshot of the ad as it appears in Brave

Did the issue present with default Shields settings? (yes/no)

Does the site function as expected when Shields are turned off?
Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

Does the site work as expected when using Chrome?

Brave version (check About Brave):
Brave is up to date

Version 1.56.20 Chromium: 115.0.5790.171 (Official Build) (64-bit)

Help here.

1 Like

Can you please visit brave://components (in the URL bar) and look for the Brave Ad Block Resources Library item and click Check for update. Then reload the YouTube page
We have an update just published in version 1.0.54 which will fix you up :slightly_smiling_face:


Thank you so much so far this has seemed to have fixed the issue :slight_smile:

I tired to doing that and it says full updated to 1.0.56 but still getting ads

@dasva I’m locking this topic because it was solved for OP. What I’m going to ask you to do is to create your own topic. When you do, make sure to include as much information as you can. If you need help on knowing a bit more of how to do all of that, you can check out Creating Topics

Key things to share:

  • Which version of Brave you’re using (put actual version number, don’t just say “the latest”)

  • Which OS? (Such as Windows 11, Android 12, etc)

  • What Shields settings are you using on YouTube? (You can click the lion icon and screenshot that)

  • Do you have any content filters activated?

And some guidelines on perhaps best Shields settings and some troubleshooting steps you can try are in links below: