Didn't receive March payment && Partial April Payment

Briefly describe your issue:

I haven’t received my payment for March on this PC at all. I’ve received some sort of partial payment in 3 small payments for April.

Aprils payments: 3.295 \ 3.765 \ 0.25 when they were 5.648 and 5.102BAT.


What Operating System and Brave version are you using (Menu --> About Brave)? Version 1.24.86 Chromium: 90.0.4430.212 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no) yes

What date did you verify your wallet? 1/18/21

Have you been able to successfully receive payments in the past? yes

Are you using a VPN? (yes/no) no

Are you in a supported region (see here for list of supported regions)? yes

Does your device pass the SafteyNet check (Android only)? n/a windows

Have you manually turned off Auto-contribute on all of your devices linked to Uphold?? yes

@eld00f,
Thank you for reporting! Please DM with the following information:

  • Copy/paste your Wallet ID (found on brave://rewards-internals )
  • Your OS and Brave version (first three lines in brave://version )
  • A screenshot of your Rewards panel in Settings --> Brave Rewards

Please include a link to this thread in the subject line of your DM. Thank you!

I sent the information over a week ago, you said thanks. There has been no indication that I’ll be receiving payment for the lost BAT. Is it gone, or is there actually something being done about this? I see a lot of the “we’re looking into this” and no one actually saying they’ve received any resolution to their issues.