Clipt Extension not working in Brave Browser

Description of the issue:
The Clipt Extension doesn’t work in the Brave Browser since yesterday. The issue appears saying ‘Sign in failed. Please try again’.

I tried in a New profile, doesn’t work in a New Profile as well. Doesn’t Work in Brave Beta as well as Nightly.
Works perfectly fine in Chrome. So seems to be an issue with Brave itself. Seems to be a problem which arised after I updated to Version 1.49.120 Chromium: 111.0.5563.64 (Official Build) (64-bit)
How can this issue be reproduced?

  1. Add Clipt in Extensions
  2. Try signing in to Google Account
  3. Click on get started

Expected result:
Should be able to sign in.
Brave Version( check About Brave):
Version 1.49.120 Chromium: 111.0.5563.64 (Official Build) (64-bit)
Additional Information:
Seems to be a problem after updating to latest version. Had not used Clipt on Beta and Nightly before having this issue on Stable version, so can’t confirm if this is indeed an issue with the Brave update or just some other issue. I have already tried removing the extension and re installing it, restarting Brave and my device but to no avail.

@Mattches @steeven please assist

So this seems to be the update which is causing the issue. Just tried on my other Windows having Brave version 1.48.171, this works perfectly fine there.

Can you check and ensure that you have the Allow Google login for extensions options enabled in Settings --> Extensions?

Thanks a lot ! That worked. Stu p id of me to not think of that, lol.
But its also a bit weird how that allowed me to sign in earlier, if that setting was off!