Can't send images via Facebook web Messenger - Images Stuck sending and never send

This is a new issue. I’ve been using Facebook’s chat messenger app in a Brave browser tab for months without issue. Within the past month or so I haven’t been able to send images (or any of the GIF etc options available in Messenger). If I attempt to send an image - text says Sending but nothing is ever sent.
I’ve logged off and back in, closed the tabs and cleared the cache…I’m on a LAN connection sending images that are 100k. Something isn’t right. I’ve also tried ‘shields down’ and it also does not work. I believe it may be related to end to end encryption. The “text” part of the message works as expected. Uninstalled and reinstalled Brave and issue persists…

It is also NOT an account issue. I tried using Firefox and it sends images without a problem. (this also occurs in Vivaldi)

I’m using Linux Mint 21.3. x86_64 with kernel 5.15.0.92-generic
Brave: [Version 1.62.153 Chromium: 121.0.6167.85 (Official Build) (64-bit)]

Any suggestions would be welcome. As I love Brave and don’t want to have two browsers open. Meh.

Is this not happening to anyone else ? :open_mouth:

sending

in the above image - each is an attempt to send an image. they are just “hang” on sending…

Thanks!

Hi
Same problem here with Xubuntu 23.10 (amd64), kernel 6.5.0-17-generic
Thanx

Thank you for reaching out to us.
Unfortunately I’m not on Linux, nor do I have a Facebook so I’ll have to see if a team member can test this and try to reproduce on our end.

Just out of curiosity, if you try to do this in a Private browsing window, do you get the same results?

1 Like

I was able to test this on macOS but could not reproduce the issue. Waiting for our Linux folks to get back to us.

huh! It actually works in private mode.

@dagsix,
I suspected that might be the case.
It could be an extension that is causing the behavior but I’m more inclined to believe that there’s some bad site data floating around.

Can you please go to facebook, click the “tune” icon on the left side of the address bar, click Site settings, then click Delete data.

Return to Facebook, refresh the page, log back in and test to see if the behavior persists.

Hmm, that seemed like a promising lead but alas in normal browsing after the data clear it is the same…

I even tried a “Clear ALL browsing data” and it still won’t send.

Thanks for the suggestion.

@dagsix are you using extensions? If so, you still haven’t gone through to test that it seems. The only real differences between private compared to normal window are:

  1. Private opens with no cookies

  2. Extensions are disabled by default

  3. All cookies and browsing history are deleted when the session ends.

So if testing on Private works, generally is either extensions or cookies. If you cleared cookies and all and it doesn’t work, we’re kind of left with the only remaining option of extensions overall.

I did figure this… I use UBlock Origin and figured it would most likely do something like this… but it is DISABLED for messenger. So…hmm. The other extensions I run are rather benign.

I also tested turning Ublock OFF at the extension level and it is still happening…

Hmm,… turned OFF ALL of my other extensions (so now NONE are running) and still the same.

1 Like

Thanks for testing @dagsix — still waiting to hear back from Linux folks about this. Hope to have more information for you soon.

1 Like

for me, the cause was an End-to-End Encryption issue . I had to deactivate then reactivate it .

Hmm, I thought that was the issue (E2E). I’ve tried the following:

  1. Select your name in the bottom left corner
  2. Tap Privacy & safety.
  3. Tap End-to-end encrypted chats, then tap Secure storage.
  4. Tap Delete secure storage and follow the on-screen prompt to confirm.
  5. Tap Turn on secure storage and select a new security method.

I added a new 40 character PIN in the “update” and it is still the same.

Also tried it E2E off/disabled and it also did not work.

:frowning:

sorry I read only one part of your initial message. The issue was for all type of messages for me , not only pictures …
Did you test with a new brave profil in Brave ?

Tried a new profile. Same result.

interesting…
You could try :

mv ~/.config/BraveSoftware ~/newdir

and retest.

As expected, that reset everything, relogged into all my settings and it is STILL THE SAME.

:frowning:

No issues on files permissions and owner in your homedir ?

Otherwise :
-is your brave browser up-to-date ?
-did you try snap version of brave ?

Or else :
maybe it’s a bug in Mint, so try https://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/

Do you find a solution ?