Can I get an older version of Brave?

UPDATE: The suggestions below might work, but what about just locking Brave in the Finder? That is, go to Applications, right-click or control-click Brave, and in the ensuing window, check the box next to Locked. In theory, that should prevent changes.


Also, it looks like the devs heard the users’ complaints, albeit too late for those using older OS. This is what I get in Nightly on Big Sur, now:
image

–End UPDATE–

It might be worth trying command line switches. Here’s a link to my source. Here are two promising ones:

  • --check-for-update-interval - How often (in seconds) to check for updates. Should only be used for testing purposes.
  • --disable-component-update - no description

I tried using both (20 years in seconds for the first) and they didn’t return an error, but I don’t know that they worked, either.

What I’d suggest is writing a tiny AppleScript to issue the command you want to try:
open -a 'Brave Browser.app' --args --check-for-update-interval=630720000 (that’s 20 years expressed in seconds); or
open -a 'Brave Browser.app' --args --disable-component-update

The script would look like this (use Script Editor image - should be in /Applications/Utilities):

if application "Brave Browser" is running then
	
	tell application "Brave Browser" to quit
	do shell script "open -a '/Applications/Brave Browser.app' --args --disable-component-update"
else
	
	do shell script "open -a '/Applications/Brave Browser.app' --args --disable-component-update"
	
end if

tell application "Brave Browser" to activate

You could do both commands by adding one after the other like this:
open -a 'Brave Browser.app' --args --disable-component-update --check-for-update-interval=630720000
I tried that and it didn’t throw an error, but, again, don’t know if it worked, either.

If you copy and paste, make sure no stray formatting codes have been included. Also, I use Nightly, so if I left that word in the app name by mistake, just omit/delete it.

Once you’ve written that in Script Editor, save it, then also save it as an Application some place you’ll remember, then go to that folder and drag the new Application to your Dock and use it to launch Brave instead of clicking Brave’s icon (every time). I do this with a script to make the cache tiny and it works great.

If you need more help, let me know. If it works, please also let me know.

Not sure what you did, but changing the feedurl worked for me…

1 Like

I guess that’s the simplest solution.

how can someone disable “auto updates”?

I need this feature as well. We started using Brave last week to get away from Firefox for daughter’s online school. We have an older mac running 10.10. Not planning to buy a new mac, not yet. This morning I discovered Brave had updated itself and of course would no longer work. Had to hastily find & download older version to get daughter going with school but I can’t keep doing that if Brave continues to update itself. This seems like a very logical/reasonable thing to have in the software. At least ASK before updating so we have a choice. Giving users no choice in the matter is more like something Gates (windows) would do. And actually, updating itself past the point of being able to function seems like something the software should detect before proceeding. Does it not?

If you read my replies to this thread, I show how to disable brave’s autoupdate…

  • Quit the browser
  • Open /Applications/Brave Browser.app/Contents/Info.plist
  • Change the URL value of SUFeedURL to soemthing that doesn’t go anywhere like https://127.0.0.1 - Copy the old address somewhere to be able to change the value back.

  • Save changes
  • Open brave browser and possibly relogin to some sites…

:nerd_face:

1 Like

Thanks. Will dig into that. I also used another suggestion above and locked the app.

Please refer to my comment here for information on this:

1 Like

Firefox was working fine. I stopped using it and uninstalled to move to Brave. I don’t think Firefox was updating itself as I’ve had it for years and that hadn’t happened. Normally, seems like it would notify me of an available update, but did not force it on me. Perhaps it was about to and I just happened to uninstall right before?? Don’t know. Regardless, it’s a bit “nanny-state” to write software that doesn’t give users the option to make our own decisions regarding updates. Just my humble opinion, of course. Hoping the app lock or other above suggestions work so I can continue using Brave. Thanks for the notice.

Much more elegant, @megaspaz. Nice work.

FWIW, using Finder’s “Locked” option also worked; the installer can’t copy the updated file into the application’s Contents and reports as much, then gives up when dismissed.

Hi, @JTKing. Brave Nightly now notifies and gives the option to skip, at least. Not sure exactly when that will make it to Release, but probably not too long. Click images to enlarge.
image

I’ve used Nightly for years with no major calamity if you want to get that feature now. This link will take you to the Brave Github Releases page, which lists all the Release, Dev, and Nightly versions available for download.

If you do switch, you can easily move all of your bookmarks after you launch Nightly and quit it again. Just copy your profile folder (Default for “Profile 1” unless you’ve created additional personae, in which case it will be Profile #, # being 2 or higher) from
~/Library/Application Support/BraveBrowser/Brave-Browser/
to
~/Library/Application Support/BraveBrowser/Brave-Browser-Nightly/.
image

Thanks!! Will check into that if it remains an issue.

SUFeedURL change does not work on mine. It quits on Brave startup, never opens a window, just pops up this error box.

BQ

I’ve already updated my OS a couple times past what Apple will officially allow but this is as far as I can go for now. One of the reasons I was using Brave is that both Firefox and Chrome are no longer compatible. At least with Firefox I can decline the updates. I guess I’ll go back to that.
Another disappointment with software creators.

OSX

What did you change the value to? What does your plist file look like? What did you edit the plist file with? Either way, something like this change would be a data change and not affect usability… The locking brave in Finder like @hnktong suggested also would work… :wine_glass:

I have tried a few things:
01
127.0.0.1

02
the duck duck go start page

03
brave(dot)com

and a few others. Some real websites, some not. None work.

Brave only starts with the updates.bravesoftware update URL:

locked
I do have Brave locked and set to read only. Does not seem to keep it safe as it updated again about an hour ago - which I trashed and reinstalled my last working copy which still works but is a bad work around.

@AlbDavidT,
You can force-disable updates to the browser by launching it from the terminal with the appropriate flag, as described in the comment I linked to above:

And here is an easy way that modifies the Preferences.

If you don’t already have a Preference Editor, download (free) Pref Setter from http://www.nightproductions.net/prefsetter.html (current version is 2.0 - I used 1.2.2)

Launch Pref Setter and find com.brave.Browser is the list of Preferences (Pref Setter knows where the Preferences hide)

Set the booleans for SUAutomaticallyUpdate and SUEnableAutomaticChecks to false by clicking on true if the setting is true.

Save your changes (Pref Setter knows where they hide) and you’re done.

I use Safari, Firefox, Brave and TOR browsers. Whichever one to use is a snap because I have installed the Choosy addon which allows me to choose whichever Browser I want at any point in time. Highly recommended, I use it 100 times a day, and it wasn’t expensive. I’ve had it for years. see:

I’m using the Choosy.prefPane 1.1 which works in MacOS 10.9 and later which I purchased years ago.

Do not use Choosy 1.2 because it requires MacOS X 10.12 ie NOT Yosemite.

https://www.choosyosx.com