Brave is sharing tabs to chrome on different computer even though sync is disabled

Description of the issue:
I have two laptops.
I have Brave installed on one of them.
I have Google Chrome installed on the second one.
In Brave on laptop 1 I have sync disabled (I open preferences, click Sync and see “Start using Sync”. If I click on that I see “Start a new Sync Chain” so, I have to assume Sync is not currently enabled.)
On laptop 2, in Chrome, I’m logged in to a google account, but under Chrome’s sync settings I have Tabs disabled.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
On laptop 1, in Brave, open a tab and go to
Screenshots are before/after of opening a tab and going to in Brave on laptop 1.
In screenshots “laptop 1” with Brave is the bottom laptop, “laptop 2” is really a second laptop. Screenshot shows external monitor on the top.

You can see the shard tab pop up in the dock on laptop 2 (external monitor). If I click it, Chrome opens and goes to

Actual Result (gifs and screenshots are welcome!):
Shared tab pops up on Laptop 2 in Chrome.

Expected result:
Shared tab does not pop up. Sync is disabled.

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
OSX 10.15.7 - on both laptops
Brave 1.15.76 on laptop 1
Chrome 86.0.4240.198 on laptop 2

Additional Information:
Fwiw what it’s worth, I also have sharing tabs disabled in iCloud settings for Safari, but am not using Safari for this example.
I used ‘’ in this example which is not my default homepage. This issue happens with any URL.

Hi @jaaaaasshh,
Can you go to system preferencesgeneral
What is your default Browser?
Is handoff enabled?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.