Brave is Blocking Every Website with "Deceptive Site Ahead" Message

Hey Dudes,

I clicked a link from a Wikipedia article and got the bright red screen:

Deceptive site ahead

Attackers on 1637314617.rsc.cdn77.org may trick you into doing something dangerous like installing software or revealing your personal information (for example, passwords, phone numbers, or credit cards). Learn more

It didn’t really make sense, but after a few attempts I tried to look up the subject via search engine and immediately got the red screen and same message.

No matter what page I look up now, even simply Google or my email, the same thing happens–another ! Dangerous warning in the search bar and the red screen.

The only way out is to click on the ‘details’ button, then directly access the page through the ‘visit this unsafe site link.’

This has never happened before, but now it is the same for every web address.

I have tried dropping the shields and messing with the site settings, but no luck.

Brave Version: 1.24.85 Chromium: 90.0.4430.212 (Official Build) (x86_64)

Thanks in advance for any input.

Yours,

-W

For a brief moment, the website will appear like normal then suddenly it’s this red screen every single time.

This is very strange. That warning page is coming from Google Safe Browsing, but that site doesn’t appear to be on their list:
https://transparencyreport.google.com/safe-browsing/search?url=1637314617.rsc.cdn77.org

Can you share a screenshot of what you see on brave://safe-browsing/#tab-db-manager?

OK… Oddly enough, websites seem to be loading fine now. I didn’t change any setting, so it’s a good thing but also very confusing.

Here is that page you mentioned:

the only think i can guess that lead to that issue that wrong time on your computer clock
could you check when that happen that your time on your device is correct