All Discourse forums that use the Splash feature to pre-load assets are broken

All Discourse websites that use the new splash feature to pre-load all site elements are broken. The website loads but fails to be navigable due to what looks like a bug in Brave’s security model.

The following error occurs due to a failure to properly parse the inline script.

The line that triggers this fault is:

<script>// This script is inlined in `_discourse_splash.html.erb

When using incogneto mode, this problem dissapears. A fresh install of Brave on Debian with a brand new profile and no plugins also exhibits this behavior. Disabling “Brave Shields” has no effect.

Even this Discourse exhibits this fault, to reproduce simply load this Discourse forum.

2023-01-24-113812_485x42_scrot

Brave Version( check About Brave):

Additional Information:

@gnif Welcome to the community.

I can’t help. I am just posting information that Brave support or another community member will probably need you to do to help troubleshoot your issue.

  1. Your Brave (1.45.131)/Chromium (107.0.5304.110) are out of date. The current versions are Brave 1.47.171 Chromium: 109.0.5414.87. Please update to the latest version. This may solve your issue with no further action. There were Chromium issue reports of response code/source map errors in Chromium 107 which appear to be fixed in later versions.

  2. Please provide the version information for your Debian OS. You can find it at brave://version. If it too is outdated, an update may also solve the issue.

Please post an update. Take care.

2 Likes

Strange bug, but yes, I can confirm that upgrading to the latest stable version has resolved the issue, thanks. For some reason I thought I had already done so.

1 Like