Titles of Tabs unreadable in new update

I don’t know what’s going on but it is super super annoying.
The issue started yesterday and it’s still there today. All my new tabs’ text is super bright. Great. Impossible to work properly. Gonna change my browser if it’s not fixed soon.

2 Likes

Pretty incredible that this change went through. All non-focused tabs with this configuration is unreadable and breaks visual accessibility. Hope this gets sorted out and fixed quickly.

Reproduce by having these settings in Windows:

and these settings in Brave Profile:

The fix mentioned in an earlier post is not a valid solution, as toggling the checkbox “Title bars and windows borders” off affects every single window in Windows.

2 Likes

It started for me when it updated to latest version on launch.

I’ve been using dark mode for a few months without issue, text was white against the dark tabs. Now the text is black and invisible. Screenshot:

1 Like

Having the same problem! I appreciate the workaround in Chocoholic’s linked post but I definitely wouldn’t consider that a fix. If Brave respects the Windows theme’s text color it should also respect the rest of the Windows theme. It can either do both or do neither, but one and not the other is a bug.

Ouch. Sorry about that and sorry to all the others who tried this. I posted that fix in several topics and several users reported it worked for them. The users who said it worked didn’t mention it changed everything in windows too! It isn’t something that I’m experiencing so wasn’t able to test on my end.

1 Like

This seems to be an effect for some users after they update to the new version. The workaround mentioned by @fictive of disabling that windows setting is in the link below. And, as has been pointed out, changing that affects all the system windows although it does allow you to read tab text in Brave. I don’t think anyone knows exact steps to recreate this issue (yet).

Edit: Updated Google Chrome and I do not have an issue there either. Has anyone with the issue updated Chrome and does the issue occur there also?

Version 1.37.109 Chromium: 100.0.4896.60 (Official Build) (64-bit)
Windows 11 21H2
Titles suddenly unreadable, light white on grey tabs

Repeat of my post elsewhere.

If it’s any use, I may have figured out what is happening.

I had a look at the “chrome” around the edges of various program windows.

I think Brave tabs may be picking up the font colour from the Windows system palette, but setting the background to a fixed colour.

Hence the mismatch and hence some people see different things.

Hello all …
I found a very good workaround for this problem I think.
You have just to choose another color than the default one and then the color of the title of tabs will be black and the windows colors config will have no effect on brave.
take a look :
brave_tabs

10 Likes

Thanks Z75, that’s a better solution than unchecking the box in Windows settings, which negatively impacts the rest of Windows applications. And thanks for supplying a video, I’d have never found those color settings otherwise. You’d THINK those theme color settings would be under Appearance rather than “Get Started → Profile name and icon”.

Thanks for the tip. Someone else recommending changing the Brave colors to dark, and that helps. Rather not mess with Windows system palette.

Trisha

Just to add to the discussion, you can even choose White (R255, G255, B255) and it fixes this problem. Your color palette doesn’t have to be dark.

Thanks for the video, this is great!

1 Like

Thanks, this worked for me

1 Like

Issue report opened on Brave GitHub.

1 Like

Super! thanks. This worked for me too!

1 Like

Fix released in Brave Release version Release Channel 1.37.114.

  • Fixed unreadable tab names when using certain accent colors on Windows. (#22027)
2 Likes

I’m on 1.37.116 and the issue is not resolved in dark mode. The selected tab is white text but the tabs not selected are not readable due to very dark text against a black tab background

@Utidiysyisitdixoxohd I wonder if anyone else is experiencing this, especially with dark mode. I haven’t seen any recent posts about the issue. You should probably tag the moderators in your support request to let them know you are still having an issue. You should edit your topic to indicate you are updated to the latest Brave version and also include any additional information you may be experiencing related to this issue. You could also DM them too. Or do both! Up to you. :smiley:

Yes the issue is still present for WIn8.1 users and fixes are planned according to recent post here:

1 Like

@Chocoholic ,

Tab title character strings are OK, but not the URL address field character strings. I am mentioning the problem, here, because of the tendency by developers to invert appearances – and thus cause undesired appearances.

I use Light color, and I guess that is effectively a “Light mode” at brave://settings/appearance

But, I also use New Private Window(s), and that – for reasons unknown – causes semi-visible characters in the URL address field:

If I select the URL address character string within the URL address field:

That poor visual performance, has routinely been an issue for all versions of Brave Browser, back in time . . . for Mac OS v10.12.n “Sierra” . . . re my Mac computer.

1 Like