Can't log into X (twitter) suddenly

Suddenly today, I can’t log into X on Brave. Tried on Firefox, works fine. Worked this morning okay. X wants me to log in, then says “Oops, something went wrong”. Seems to be just with this browser, and just today…

exactly the same now happend on my side … can log into twitter on any other browser, but it’s broken on brave.

hard reload didn’t help.

Same here, how do you guys solve it?

does it work in private window mode? try clearing the cache

Funny. Same thing happening to me. Cleared cache and still not working although working in a private window.

any extensions installed?

No extensions. Toggled developer mode on and off and didn’t work in either variation.

I also can’t log in to Twitter. Just tried today (Feb. 24). This is on Windows 10. I tried disabling Brave Shields, to no avail.

Same thing, suddenly can’t login in x.com clear cache everything. Just work in private mode

Same here. Extensions or not, cleared cache and works fine ONLY on private.

For god’s sake, everything is broken with the latest update. Can’t log to twitter, youtube has playback and audio issues, browser itself is unstable, just what is going on…

I have nothing relevant to add apart from that I am experiencing the same issue. Just want to refresh the topic because I see there is no solution yet.

1 Like


Nothing changed still not working!

Same here. Works only in private mode