Brave Browser on Fire TV

Description of the issue:

I’m trying to reinstall the latest version of the Brave browser

Operating System and Brave Version(See the About Brave page in the main menu):

I’m installing this on an amazon fire tv. There was no option to choose amazon. The android version doesn’t work on Amazon. I was using the version that was linked to me on the github but I can no longer find it. Can someone here please post the correct link so I can install this on the Amazon fire stick?

Additional Information:

I had the old version and tried to update it with a new one I found on APK pure. That version didn’t install and says it’s corrupt.

Could I use one of these and if so which will work on fire tv?

@incohearence,
The versions you are linking to are outdated. I’m not sure we support the fire tv stick. Were you able to do this previously at some point?

Yes, I was able to do it off this post. Sideload brave browser on amazon fire stick

No when I enter https://www.apkmirror.com/apk/brave-software/brave-browser/brave-browser-1-24-85-release/
in to the downloader on fire tv it says Error: Forbidden. Try using https if you used http. Maks no sense. I used http.

I need to get this to work and it worked before so I don’t understand why it won’t work any longer? If it works on abdroid it shoudl work on fire tv.

@incohearence,
We recently switched to .aab file types for Android, which may not be compatible with the Fire tv stick. You should still be able to install older versions via .apk and we are working on making .apk files an option in the future as well.

That said, the reason your mirror website you’re using isn’t working is because that file does not exist (the .apk). Here is the Github page for that release:

Also note that version 1.24.86 is actually the most recent build.

O ok. Can you provide the link to the one I need to use?

@incohearence,
Until we start releasing .apk files again I’m not sure you’re going to be able to install Brave on the Fire Stick. That said, I’m actually not sure whether or not .aab files would install on a Firestick – can’t hurt to try.

Ok. Which one in that list would I try?