Block Facebook Sponsored Posts

Description of the issue:
Facebook sponsored posts still show. I might be because of the random insertion of letters in “Sponsored”, see

Exact URL of the website in question: logged in on brave browser

Screenshot of the ad as it appears in Brave

Did the issue present with default Shields settings? (yes/no)
default yes

Does the site function as expected when Shields are turned off?

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

Does the site work as expected when using Chrome?

Brave version (check About Brave):
Version 1.8.86 Chromium: 81.0.4044.129 (Official Build) (64-bit)

1 Like

The reason these show is because they are – due to the way FB serves it’s ads – technically first party ads, which are not blocked by default.

However, we do have a more aggressive option for Shields that will block any/all ads and trackers regardless of party status – this change is currently in Brave Dev and making its way down the Release pipeline. When you get the update, you’ll see an option like this in your Shields panel:

Selecting the (Aggressive) option will block the sponsored FB ads you’re seeing as well.


Note, Facebook are notorious for evading adblocking tools. It wouldn’t be surprising these are showing up. They using same page elements of user posts and ads, making it harder to block without creating false positives.


@Mattches @fanboynz Keep up the good work, and the good fight! :ok_hand: :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.