Yubikey not working using Brave on Ubuntu 20.04

Yubikey not working using Brave on Ubuntu 20.04. Brave version is Version 1.14.84 Chromium: 85.0.4183.121 (Official Build) (64-bit)

Using https://demo.yubico.com/webauthn as a test website and using the same laptop and OS in testing.

The Yubikey works fine when using Firefox and Chrome, but Brave refuses to detect the Yubikey . No error in Brave beyond an eventual time out waiting for the Yubikey response.

Does anyone else have this issue and or can try and replicate to see if this is just my config? I have to switch to Firefox so I can login to any services that require the Yubikey currently which is annoying but survivable. So this is not a critical issue by any means.

1 Like

Hello @ahunter

not sure if that would help or not
try to enable this and see if it works
brave://settings/content/usbDevices

and have a nice day :slight_smile:

Hi @justsomeone1,

Thank you for that. I completely forgot to mention that I had tried that setting already. It’s currently set to ask when a site wants access. The only other option being to turn off all access.

Hope you have a nice day too.

you very welcome

2 things to check also

  1. does turning off the shield make any defferance
  2. could you disable all extension and see if it make differeance

and thanks :slight_smile:

Hi,

Sorry for the delay in responding. Notifications were not working so I thought this topic had no updates.

I have done as requested and it made no difference.

thank you

it’s ok do not be sorry let me ask someone from the team to help you @Mattches
and have a nice day both of you

@ahunter,
I see that we have an issue that was just opened for this – this wasn’t you by chance was it? :slight_smile:

Nope. Not me, but good to know I am not crazy.

2 Likes

I’ve just tried the test website on Brave 1.15.76, Ubuntu 20.04 and a YubiKey 4. Everything worked for me.

Which YubiKey do you have? Does it work on other websites in Brave, for example, can you add it to your account on this website (community.brave.com)?

1 Like

Hi,

I have updated Brave to the same version as you used. (1.15.76) Testing in my gitlab instance and via https://demo.yubico.com/webauthn yields that same results as before in Brave. The Yubikey does work in Chrome and Firefox on the same laptop. I am using a Yubikey 5 NFC.

I get the same results trying to add the key to my account on community.brave.com. A little window pops up that says touch your device, but the yubikey never starts flashing. It does flash if I use Chrome or Firefox.

Are you using the Ubuntu packages from our official repository (https://brave.com/linux/#linux) or are you using the Snap?

I am using the Snap.
snap list
brave 1.15.76 82 latest/stable brave

That’s probably why I couldn’t reproduce your problem. There might be a permissions issue with accessing USB.

I filed an issue to track this problem:

In the meantime, I would suggest switching to our official packages if you can.

1 Like

To Confirm - This now works when using the official repo.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.