YouTube "watch later" button from suggested videos sometimes changes page

Description of the issue:

While watching a video on YouTube, I enjoy adding suggested videos to my “watch later” list. I did that very often, using Google Chrome.

Since I switched to Brave, it happened many times that clicking that button redirected me to the page of the suggested video, instead of just adding it to the “watch later” list and letting me watch the video currently being played back.

Quick screencast recording showing this behavior: https://youtu.be/_dplfBI_AIE

How can this issue be reproduced?

  1. Go to youtube.com, play a video
  2. While it’s playing, hover a suggested video and click on the “watch later” button
  3. If it does not redirect, refresh the page and try again

Expected result:

Instead of redirecting, the browser should stay on the current page and replace the “+” (plus/add) icon of the button by a “:white_check_mark:” (check tick) icon.

Brave Version( check About Brave): 1.9.76

Additional Information:Preformatted text

Hi @adrienjoly,
I can’t seem to recreate the issue. Can you try creating a new test profile and seeing if the issue persists?
Click on the menu icon in the top right corner > create a new profile.

I’m going to try that.

In the meantime, I have another hypothesis on how to reproduce this behavior: try to Re-add a video you had already added to “watch later”, after refreshing the page. Can you give a quick try and tell me if this works on your end?

I’ve tried re-adding, I don’t experience the same behaviour. Did the new test profile work properly?

I experienced the same behavior:

  • from a new/blank Brave profile (as you suggested)
  • from a private window
  • and after I disabled all extensions, in my own Brave profile

I was able to reproduce that behavior systematically by clicking the “checkbox tick” icon of one or two suggested videos, from https://www.youtube.com/watch?v=NHHhiqwcfRM => one of them will actually follow the link to that video right away, whereas it should just have added it to my “watch later” list.

Edit: Since my initial post, I updated to Brave 1.9.80.

@adrienjoly,
Apologies for the delayed reply. Are you still experiencing this issue after updating to the newest version of Brave?

Yes, it does, unfortunately.

Can you confirm this does not happen with Chrome or any other browser?

I confirm that is does not happen with Chrome.

That said, I was able to reproduce the anomaly on Firefox.

Can you try disabling hardware acceleration via brave://settings/system, this may not work but I still want to tick it off the list.
I’ll make a note of the issues and speak to the team to see if we can further diagnose or solve the issue.

I just did => I experienced the same anomaly after disabling hardware acceleration and restarting brave.

While discussing the issue on Twitter, Sampson came up with an interesting hypothesis:

If clicking that button doesn’t add it to the view-later list, I suspect it’s a hit-marker issue. Can you try the repro steps again, but this time being very careful to click exactly in the middle of the icon?

=> I tried, and it looks like this hypothesis is correct! (cf the video below)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.