Youtube playback stutters / Possible CPU util issues

bug

#1

Brave: 0.20.42
V8: 6.4.388.41
rev: 096c7cb3c75ebb518f72fc7d24bc2bbaedd50aed
Muon: 4.8.2
OS Release: 16.7.0
Update Channel: Release
OS Architecture: x64
OS Platform: macOS
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 64.0.3282.140

OSX 10.12.16

I don’t have reliable steps to recreate but essentially after not closing the browser for an unknown amount of time the browser seems to have some sort of CPU/Memory issues. Playback stutters when using the browser. I have observed this in both Google Play Music and Youtube. The only way I can describe it as if the browser was locked in a single CPU thread with a limited amount of CPU resources. If I scroll around or use other tabs while playing audio/video, the playback stutters a lot. A restart of the browser clears it up. I only began having these problems in the past 3+weeks.

Next time this happens are there any other stats that I can capture to try to help diagnose this issue?


Brave is using 250GB of HDD
#2

So I hit the problem again and one thing I wanted to look at was total thread count. I noticed that the main Brave process has 172 threads. I have 10 tabs open at the moment and the Brave Helper processes each have 10-20 threads. Is Brave perhaps doing some strange with its threading code? Perhaps opening so many threads that things go wrong?


#3

I now this is related to recent logging changes. I remember a PR within the last month or so that increases the logging output. I suspect my performance issues are I/O related or threads dedicated to writing these logs.


#4

i’ve experienced the same kind of issues with performance drops after running twitch streams and multiple browsers. once the chugging happens, closing tabs does not resolve the issue. only closing brave completely (and losing all tabs) gets the performance of the machine back.


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.