Youtube menus do not work anymore

Description of the issue:
Since today, most menus on Youtube do not work anymore unless I de-activate Braves tracker & ad blocking.
On Youtubes start page, my personal subscriptions page, and indivicual video pages, the menus with options to ad videos to playlists, the bell icon menue, and the menu with URL links to share videos no longer work.
Oddly, when on a playlist page, the menu to add videos to (other) playlists does work.
After switching off Braves function to block ads and tracking for youtube, the menus work as normal.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to youtube start page.
  2. log in if not automatically logged in
  3. click on the bell icon
  4. click on the icon with 3 dots under any video preview picture (it appears right of the video title, when you move the mouse pointer on the video preview picture)
  5. click on any video
  6. click on the ‘save’ menu
  7. click on ‘share’
  8. switch off Braves function to block tracking and ads for youtube and repeat steps 3 to 7.

Actual Result (gifs and screenshots are welcome!):
In cases 3 and 4, nothing happens.
In cases 6 and 7, the window content becomes darker but no menu appears.
In case 8, everything works, but ads and tracking are not blocked.

Expected result:
Menus appearing with tracking and ad blocking activated.

Reproduces how often:
always

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS 10.12.8
Brave: Version 1.28.105 Chromium: 92.0.4515.131 (Offizieller Build) (x86_64)

1 Like

Open brave://adblock and add youtube.com#@#.ytd-popup-container in the Custom Filters textbox at the bottom of the page.

For some reason the custom filter doesn’t work all the time, refreshing YouTube might be needed.

1 Like

That does not work.
I closed and reloaded brave://adblock to make sure the custom filter was saved. It was.
I reloaded youtube pages. I opened a new video page. I closed and restarted Brave.
I reloaded brave://adblock. The new custom filter is there.
Menues still do not work.

1 Like

I got you. I’m having the same issue as you, the custom filter works sometimes, sometimes it requires a couple of YouTube refreshes to begin working again.

When did that problem start for you?

It all began a couple of hours ago, after Brave’s component updater updated the filter lists.

@fanboynz reverted the commit above, but it will take a few hours until the component updater updates the filter lists again.

1 Like

I refreshed a few pages a couple of times. Occasionally, the filter you provided works. Thank you.

Typically, for new youtube tabs, it does not work. Seems that each new tab needs to be refreshed about 10 times before it works for that tab.
Better than nothing though. Again, thank you.

So the automatic update process is supposed to roll back the update that caused the problem?

Technically, it won’t roll back the update itself. The automatic update process will push all new changes that have been committed in between the updates, one of those commits is the removal of the problematic YouTube filter.

1 Like

Problem started few hours ago for me as well. Tried everything but still doesn’t work…

Note that developers are aware of the YouTube issues.

If the removal of the YouTube filter doesn’t resolve the issues, I’m sure they’ll commit another fix that will resolve the issues as soon as they can.

‘From time to time’ is not what happens here. It’s always.
But I am happy to live with the workaround that you provided if that is only a temporary inconvenience.

In Watch Later i click on three vertical dots to see the context menu for every time and nothing happens, same issue.
Adding filters didn’t help either.

Using Brave Beta, just updated and as soon as Brave Betas updated, I can’t access menus or notifications in Youtube. Never had this issue before.

Update: Didn’t do anything at all, but came back to Brave later and it all appears to work again.

In brave://components/ Update “Brave Ad Block Updater” too Version: 1.0.1030, then refresh the page @Kain_Tunziano @titicaca @eyeq @phloam

3 Likes

Thanks! That helped after I updated it and re-launch the browser.

worked. thank you. :slight_smile:

Thank you, but ended up not needing this. For some reason, after awhile (with the browser closed) when I cam back to it, it was working.

It wasn’t a simple refresh because I had tried that multiple times before creating an account here just to post, but for some reason, it is working now.

Thanks again though and I appreciate your quick response.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.