YouTube/local video file playback has extreme stutters, audio completely fine

Description of the issue:
After playing a graphically more intense game (Horizon Zero Dawn), YouTube, Twitch, Reddit, Discord or any other form of video-playback is extremely laggy and runs on like 2fps, but the audio is completely fine. Otherwise everything is working normally. Only happens with Brave, this issue doesn’t occur in Chrome or Edge.

How can this issue be reproduced?

  1. Play a graphically more intense game
  2. Try to play a YouTube video afterwards

Expected result:
No stutters.

Brave Version (check About Brave):
Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (64-bit)

Additional Information:
I already tried:

  • Disabling hardware acceleration in Brave settings
  • Creating both a guest and a completely new profile with no extensions or similar
  • Re-installing my latest GPU drivers
  • Completely rebooting my PC

The attached video shows how it looks like (no audio because not directly necessary). I can move my cursor around without any lags or so, just the player has heavy issues. Task Manager isn’t showing any unusual spikes in cpu/gpu/ram-usage either, it also isn’t any internet connection issue.

System Info:

  • OS: Windows 10 Pro
  • CPU: AMD Ryzen 5 2600X
  • GPU: Nvidia GTX 1650

@Das_Unterstrich

Issue raised at GitHub, by @Mattches (Brave Support)

At the Brave Community, since last fall (2021), there were several issues where an adjustment to ANGLE GRAPHICS (Brave flags / computer settings) would seem to fix some issues.

Some Brave Browser users opened a New Window to brave://flags and made an adjustment re ANGLE graphics or something.

Some users also made a change for their display(s) (NVIDIA / OpenGL / D3D11 / Metal). I do not recall the details.

This issue seems to be a different one, I never really even saw this autoplay info/permission field appearing and after checking in my Brave settings it’s enabled anyways. Turning it off/on again doesn’t change anything. My issue isn’t about the YouTube player pausing, it is about it being very laggy (see my attached video).
It also happens always, regardless if I change volume or quality, I’ve just changed the quality of the YouTube video in my example to show that it isn’t a problem of like slow internet speed or similar.

Disabling Hardware acceleration will cause more stutters

For me there isn’t any difference between having it disabled or enabled and many suggested solutions to similar problems have it disabled.

What does More ToolsTask manager show?

Also any other applications, games using the GPU (assuming using GPU acceleration) during the playback.

I’m not really seeing any unusual or high activity, from usage it’s very similar to just a normal Google Chrome session where I don’t have stutters. I have any games closed, this stuttering is occurring independently from any other process, it even happens directly after I start/reboot my pc.
My PCs Task Manager isn’t showing any unusual usage either.

@Das_Unterstrich,
Any extensions installed at this time?
Additionally, I’d be curious to see if you see this same behavior in a fresh profile.

I have some extensions installed, however disabling them didn’t change anything, this even happens on a completely fresh profile.

If you turns Shields off while video content is playing does this have any effect?

No, still the same issue.