YouTube direct URL or search doesn't work (blank page)

Description of the issue:
If I enter a URL of a YouTube video directly into the address bar, or I use the YouTube search feature within the address bar, then nothing happens. The page is blank.

However, if I just go to youtube.com and then enter the video code or search for a video then I can navigate YouTube as per usual.

What’s going on and what can I do to fix this?

**Steps to Reproduce (add as many as necessary
Just enter any shared video URL e.g. https://youtu.be/OlNLBDYjJ2Q
Or try to go directly to a user channel, e.g. https://www.youtube.com/user/gijody

Actual Result (gifs and screenshots are welcome!):
[how to upload screenshots here?]

  • The YouTube banner appears at the top of the page, and the tab lists the YouTube / channel title
  • Also, the YouTube search box appears on the top, but it doesn’t work if you try to search for anything
  • The rest of the page is blank.

Expected result:
Normal YouTube page showing the correct page.

Reproduces how often:
Every Time

Operating System and Brave Version(See the About Brave page in the main menu):

Windows 10
Version 1.18.75 Chromium: 87.0.4280.101 (Official Build) (64-bit)

Additional Information:

Hey @orish

Can you clear the cookies and cache (for youtube), and re-login to youtube? Direct links should be treated no differently than other links on youtube. As another option, test in private window mode.

Thanks, I did all that. Doesn’t work in private mode. Works in Google Chrome no problem.