Youtube Dark Mode issue

windows

#1

Hello,

I’ve noticed, that specifically Dark Theme setting on Youtube doesn’t get saved on Brave browser (v0.19.88 – newest as of 16.11.2017). If you refresh the page, everything stays black, as it should, but if you reopen the browser, Youtube is switched back to the White Theme every time.

I also tested the Dark Theme on Chrome browser and it stayed on, as it should.

Steps to reproduce:

  1. Open “youtube.com” through Brave browser
  2. Log in (if you haven’t)
  3. Click on your avatar and from the drop-down menu choose Dark Theme
  4. When popup displays, tick to enable the Dark Theme
  5. Page turns dark, now close the browser
  6. Reopen it – The tick box is unticked and page has been reverted back to the White Theme

#2

Could you try changing cookie setting to allow all cookies and check if it is retained between restarts


#3

Same issue here for quite some time. Settings that are not saved between sessions are :

  • Dark mode
  • Autoplay settings
  • Player settings ( such as the speed of the video stream ).

Tested with ads blocked, brave ads, no cookies, no third party cookies and all cookies allowed, the results were the same. Just tried to set some of the youtube/google cookie to not expire, I’ll update this if this work when I test again.

Edit : Ok, so for now I think changing the cookies ( llbcs, wide and YSC ) to not expire at the end of the session seems to be a workaround. They seems to expire even if the session isn’t ended.

Will update again if needed.

Edit 2 : A couple days later, the got to reset everything again :confused:


#4

I would like to comment that this issue still persists. It is very inconsistent in maintaining the dark theme and is pretty frustrating.


#5

This is still an issue, YouTube player settings, dark theme etc are not saved, reset each time browser is closed :confused:

Version:

Brave: 0.21.18 
V8: 6.4.388.41 
rev: 580be782bc37ed8580dd22f79e1d2d355fddfb89 
Muon: 4.8.2 
OS Release: 15.6.0 
Update Channel: Release 
OS Architecture: x64 
OS Platform: macOS 
Node.js: 7.9.0 
Brave Sync: v1.4.2 
libchromiumcontent: 64.0.3282.140[/spoiler]

#6

You need to enable Allow all cookies on YouTube and not delete the cookies when closing the browser for it to retain the settings across session.


#7

I have the same problem. my YouTube settings are not saved, despite allowing all cookies and not deleting any content when closing the browser. Sometimes it even resets itself while the browser is still open (‘session expired’ would be my guess since it happens after I don’t use YouTube for a few hours).


#8

It could be due to cookie expiry that the settings are lost. But you will have to enabled all cookies for the player to retain settings during the time you use the browser


#9

Everything was working fine when I changed the global Setting to “allow all cookies” but only allowing YouTube cookies doesn’t work. I also allowed all Google cookies since the they are entangled with YouTube but that didn’t help either.


#10

I’ve tried allowing all cookies on YouTube, as well as blocking third party etc. Nothing seems to solve the issue at hand. When you restart the browser, you have to re-enable dark theme.

The problem still persists.


#11

Is there no possibility to fix this? This is the only reason for me to not use Brave Browser. I really like Brave Browser. A simple web browser with the smallest amount of sending user data to companies like Google. Just this one probleme so I can’t use Brave 'cause I often use YouTube and visit YouTube without Dark Mode is like AIDS for me.

Please fix it. Can’t be that difficult.


#12

Issue seems to be fixed in the newest Brave update


#13

Just wanted to add to the chorus of people here who are frustrated with this issue. Next to the “Dark Mode” the inability of Brave to save the last used screen size and autoplay-settings is my biggest grudge with the browser. No other browser i used so far had the same issues here even with adblocker on. As other posters mentioned changing the settings for cookies won’t change a thing.


#14

This is so frustrating. I have installed the browser after reinstalling windows. And I think I have to deinstall Brave again. Such a small feature with a huge effect.

Just publish a hotfix for this!!


#15

Unfortunately it’s still not fixed. I can disable shield altogether, and still no go…


#16

As of version 0.23.107, the issue of Dark Mode not being saved when restarting the browser even with all cookies allowed seems to persist.

Along with the cinema mode toggle (video size) and probably some more settings.

As others said, it’s not a deal breaker but it’s quite annoying and frustrating, seems like something taken for granted from the other browsers that when missing is really noticeable.


#17

@TimeMaster, I know this may sound strange but try the following steps in the following order :

  1. Open Brave
  2. Set Cookie control setting to “Block 3rd Party Cookies”
  3. Navigate to Youtube.com (ideally be logged off before visiting)
  4. Login to Youtube.com
  5. From here, only after being logged in, change your Cookie Control setting back to “Allow all”
  6. Finally, set dark mode theme and see if the issue is resolved
    (Note: you will likely need to stay logged in for this to work.

#18

@Mattches Thanks for the answer,

I tried the steps changing the shields settings from the page only and on the whole browser, but both tests failed.

After doing all the steps and restarting the browser, the dark theme and the size of the player are back to default.


#19

I’ll go ahead and look into this issue further but I don’t see a fix/workaround other than the ones mentioned previous. If you’d like, you can download the Developer Build of Brave which does not have this issue.


#20

@Mattches Thanks, the developer build works perfect with youtube.