YouTube: clicking on (some) playlists leads to "before you continue" message

Brave (Windows 10, [Version 1.27.111] 64 bit“trackers & ads blocked ( aggressive )”)

If you block all the cookies you normally don’t get the google “before you continue” message.
For example if you are using YouTube (watching just one video) and Google search.
Example link (no issues): https://www.youtube.com/watch?v=52GAt_fPX1k

However as soon as you click on a playlist you see the first seconds of the video AND then you get the google “before you continue” message.
Example link: https://www.youtube.com/watch?v=zkfjnd00WBw&list=PLPmusVwJ_9e_9dsvOA3xNCGzxXOpfVqRg

No issues if I use other playlists.

It’s related to the GDPR changes Google made earlier this year. I ended up creating a separate user profile where I accept their cookies because it’s the only way YouTube works normally.

I can’t tell which window you’re getting without a screenshot, so I’ll mention both.

The full-page redirect is blocked via blocking consent.youtube.com but that blocks the loading of comments.

The other consent window used to be blocked by using filters, but I couldn’t block it as we’re discussing.

@fanboynz I tried the following:

youtube.com##+js(acis, document.cookie, YES+)
||consent.youtube.com^$subdocument
youtube.com##+js(acis, navigator.userAgent, consentCookiePayload)

Also tried uBlock Origin’s solutions from this page → https://www.reddit.com/r/uBlockOrigin/wiki/solutions#wiki_consent_dialog

It’s the same issue as in the Github report but for YouTube → https://github.com/brave/brave-browser/issues/15082

@Tigershocka it looks like users are no longer redirected to consent.youtube.com, thus blocking cookies is no longer effective.

Another edit: I tested the following filter in uBlock Origin, it seems to work at first glance.

youtube.com##ytd-consent-bump-v2-lightbox, tp-yt-iron-overlay-backdrop, ytd-consent-bump-renderer, ytd-mealbar-promo-renderer

You can directly use the provided filter in brave://adblock, don’t have to install uBlock Origin specifically for it.

It was provided in the Reddit thread above. Note that I haven’t tested it for a long time, it’s still possible to break something, give it a try if you feel like it.

Thanks! I will try out.

I just wanted to mention that I don’t have this issue if I am using Epic Privacy Browser (91.0.4472.124)
Every filter list is enabled.

Does that browser have the i-dont-care-about-cookies filter list? The filter in my previous comment is taken from that filter list.

P.S You could use youtube.com##ytd-consent-bump-v2-lightbox, tp-yt-iron-overlay-backdrop, ytd-consent-bump-renderer, ytd-mealbar-promo-renderer directly into brave://adblock, don’t have to install uBlock Origin.

yes it has that filter list.

I think that Epic Privacy Browser (Link: https://www.epicbrowser.com/ ) has an internal adblocker (extension: Epic AdBlocker) which is actually ublock (modified ?). - Because if you click on the umbrella button you can see “Ublock0 - Dashboard”.

That’s the reason you didn’t see the cookie consent window in that browser. Like I wrote above, you could directly use the filter in Brave by entering it as an entry under Custom Filters at brave://adblock :wink:

Breaking the consent in Youtube is problematic, which is why it’s not included in Easylist Cookies.

Yes, I confirm experiencing issues in YouTube after bypassing cookies consent window(s), thus had to create a separate user profile where I just accept the cookies and move on.

Regarding i-dont-care-about-cookies, we’re including fixes to prevent scrollbar issues (like sites that will disable scrollbars to show consents) which i-dont-care-about-cookies can’t fix.

1 Like

I’ve added “https://easylist-downloads.adblockplus.org/i_dont_care_about_cookies.txt” but it didn’t help.

For me, there are only a few playlists where you get this message (Screenshot A, Link: https://www.reddit.com/r/uBlockOrigin/comments/lz4ibd/new_fullscreen_before_you_continue_to_youtube_page/ )

For example: https://www.youtube.com/watch?v=8OzVuxV-K2Y&list=PLgDSkClKm1k-fbS5gryLNyhkXWTjpYt9h&index=2 no problems

But (as mentioned): https://www.youtube.com/watch?v=zkfjnd00WBw&list=PLPmusVwJ_9e_9dsvOA3xNCGzxXOpfVqRg still “before you continue” message

Never had any “before you continue” message if I just watched one video (without any playlist and WITHOUT the filter list “i_dont_care_about_cookies”)

If you don’t like cookies, annoyances. Just install Fanboy Annoyances and uBO Annoyances.

Adding too many filterlists will slow things down.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.