Youtube broken with latest update

Description of the issue:
Youtube no longer “remembers” your location that you have set in your account with the latest version of Brave. I use a VPN to access the internet. YouTube is defaulting to the location based on my IP address, rather than the location I have set in my YouTube account. So instead of seeing videos in my language, I get videos in the local language based on my IP address. This is only happening with Brave. My other browsers aren’t having this problem.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Visit Youtube, click on your account icon in the top right corner. Scroll down to “location” and set it to any country, other than the actual country your IP address reports. Close Brave, then launch it again. Navigate to YouTube and your location settings have been “forgotten.”

Actual Result (gifs and screenshots are welcome!):

Expected result:
Your selected location is supposed to be saved, probably through a cookie. Brave seems to be deleting this cookie when the browser is closed.

Reproduces how often:
Every time you launch Brave and visit YouTube

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Pro 2004
Brave version 1.18.75

Additional Information:
After more experimentation I have come to the conclusion this may be a problem with cookies. After setting the locality, clicking on a video to open it in a new tab not only resets the location to the location defined by the IP address, it resets the autoplay function as well. I always have the autoplay function turned off, but upon opening in a new tab, it’s back on again.

1 Like

After some hours researching this one, the problem is with YouTube. Youtube is not setting the cookie properly for Chromium based desktop browsers as this happens with Iron and Chrome as well. There is a workaround that solves the problem…
Get an extension that allows changing the user agent. Change to any mobile Android OS. Go to YouTube and set your location. Exit the browser and relaunch. Set your user agent back to Chrome desktop and go to YouTube. Your location is now saved.

1 Like

@Sectre,
Thank you for reporting and troubleshooting. I’m glad you were able to resolve the issue and I’ve taken note of this so I can inform other users as well as the dev team about the behavior.