YouTube autoplay blocking no longer works after update

Description of the issue:
Preventing websites from automatically playing embedded media, has always been buggy. Take for example, the longstanding issue that when autoplay is blocked for a website, changing volume sliders will trigger the pause button. But update 1.38.117 introduces an entirely new bug that breaks autoplay blocking for YouTube.
Opening a YouTube video in a new tab, will now automatically start playing that video despite autoplay being blocked for YouTube, when a YouTube video was previously played during the same browser session.

How can this issue be reproduced?

  1. Set Brave to block autoplay (brave://settings/content/autoplay), and check that YouTube is not excepted from this general setting.
  2. Go to https://www.youtube.com/ and manually play a video.
  3. Open another video in a new tab using middle click or right clickOpen link in new tab (It does not seem to matter whether you pause or even close the first video).
  4. Get your eardrums ruptured by the second video automatically playing in the new tab :slight_smile:

Expected result:
I would like autoplay blocking to work at least as well/poorly as it did previously.

Brave Version:
Brave 1.38.117 (Chromium 101.0.4951.67), 64-bit

@Go-go_duck

Ref. for anybody dropping by . . .

www.youtube.com’ Site Settings (right-click on padlock icon when at the YouTube website)

The Brave URL:

brave://settings/content/siteDetails?site=https%3A%2F%2Fwww.youtube.com

Screen Shot 2022-05-14 at 11.26.10 PM

The Autoplay switch in a YouTube video window; the default at the website, is ON:

Screen Shot 2022-05-14 at 11.54.22 PM

The bug appears when I open a video in a new tab.

V1.38.119

Video open in same tab
image

Video open in new tab
image