Youtube auto plays every time I put on my airpods

Description of the issue:
Youtube auto plays every time I put on my airpods

Steps to Reproduce (add as many as necessary): 1. 2. 3.
To reproduce:

  1. Have a youtube video playing and airpods on
  2. Pause the video player
  3. Take out one of your airpods

Actual Result (gifs and screenshots are welcome!):
the video resumes playing

Expected result:
video doesn’t resume playing

Reproduces how often:
everytime

Brave Version(about:brave):
Version 0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes? My browser is up to date if that’s what you are asking.

Additional Information:
macOS Mojave - 10.14.2

Please repost (or edit your original post) to reflect the template and guidelines and we’d be more than happy to assist you.

1 Like

@radi,
What operating system are you using? This may actually be related to media “key bindings” although it may not seem to be.

1 Like

@Mattches, I updated it.

@radI,
Appreciate the additional details – really does make things a lot easier on the support side.
I’m curious – is the autoplay behavior the same in other browsers when your airpods are plugged in?

I have only noticed that in brave.

Today I also noticed that disconnecting my airpods forces a youtube video to resume playing.

@radi,
I’m actually not particularly confident that this is the cause of the issue but I have a hunch I’d like to confirm – please try the following:

  1. In Brave, type brave://flags into the address bar
  2. On the flags page, search for a flag labeled #hardware-media-key-handling and disable it.
  3. Relaunch the browser when prompted

Let me know if changing this flag helps resolve the issue or not.

This topic was automatically closed after 30 days. New replies are no longer allowed.