YouTube and any YouTube embeddables blocked in Brave when connected to a VPN

Description of the issue:
I use a VPN (Surfshark). For the past few days I kept having issues visiting YouTube - YouTube insisted I was off-line. Today I couldn’t get onto YouTube at all, nor view any YouTube embedded video on any site. When I disconnect from the VPN, I can visit YouTube again. But this issue occurs only on the Brave browser; the Vivaldi browser does not have this issue.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Launch Brave.
  2. Connect to a VPN.
  3. Visit either https://youtube.com/ or any page you know has a YouTube embedded video on it.
  4. Try either to use the YouTube site or to view an embedded video.

Actual Result (gifs and screenshots are welcome!):
On the YouTube site, a page appears saying “Connect to Internet” and the picture of an astronaut.

On a page with a YouTube embedded video on it: I see a gray screen with a picture of a square-jawed frowning man. When I hover over it with the mouse, I get a message saying that such-a-URL containing “https://youtube.com/embed/…” is temporarily down or has moved to a different address.

Expected result:
At YouTube.com: ability to view YouTube content, upload videos, and do all the usual YouTube things.

On a page with a YouTube embedded video: I expect to see the thumbnail and to be able to play the video.

Reproduces how often:
One hundred percent.

Work-around
Disconnect from VPN.

Operating System and Brave Version(See the About Brave page in the main menu):
GNU/Linux, Fedora Core 35 distribution.

Version 1.38.111 Chromium: 101.0.4951.54 (Official Build) (64-bit)

Additional Information:
This issue does not occur with Vivaldi, another Chromium-based browser.

I am experiencing this with Surfshark. I have no information on whether anyone has noticed this with any VPN other than Surfshark.