Xdg-open Error when trying to open external apps

Description of the issue:
When clicking on a link, like within the web based version of slack. The correct action should be that it opens up the slack workspace in my local client. I receive an error pointing to unable to xdg-open

Steps to Reproduce (add as many as necessary): 1. 2. 3.
RHEL 7.7, Slack desktop client installed
Open slack in the brave browser
Click on a message link

Actual Result (gifs and screenshots are welcome!):
image

Expected result:
Should open my slack desktop client

Reproduces how often:
Every time

Operating System and Brave Version(See the About Brave page in the main menu):
RHEL 7.7
Version 1.1.23 Chromium: 79.0.3945.88 (Official Build) (64-bit)

Additional Information:

That’s not an error, you’re supposed to click Open xdg-open, which would open the associated client. On Linux, you assign an app to a protocol. The slack protocol should be associated to your slack client.

Right, it does not actually open the client - it just goes out into open space.
Works fine in firefox, that what makes me think its something with a brave setup/option.

@kramer9,
Slack works for me without issue, but I’m not on a Linux-based OS. On your system, is Brave set as your default browser by chance?

cc @sriram for more info.

Hello - it is.image

That is OS level default applications. You should be able to see an entry for slack in brave://settings/handlers which may not be set. Try resetting the handlers and see if it fixes. Also just noticed you are on a really old version of Brave. Current stable release is 1.5.115 but you are on 1.1.23. I’d suggest you update to the latest version and give it a try

I do think this is it You should be able to see an entry for slack in brave://settings/handlers which may not be set. - I do not have any entries. But I also installed Brave via snap and I there are no update options there (my desktop is RHEL 7.7) - should I take a different approach to installing brave to pick up the updates? Any guidance on how to address the handlers?

@kramer9,
Definitely install Brave via the Linux install instructions found here:
https://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux

ok - once I get dnf installed and running (lot harder then you would think sadly), I will export my bookmarks, reinstall brave, and install with dnf not snap.

1 Like

Same problem here but with a different app, Myki. It pulls it up but doesn’t actually login/sync. Really irritating.

I forgot about brave not supporting RHEL, so the DNF installation path for me was not a solution. Anyone know how to set the handlers?

I have the same problem with Brave v1.5.115 in Ubuntu 18.04.

I’m not able to open anything via xdg-open, none of the links works while they do work perfectly on Chrome.

I mainly test the Zoom links.

Also, Brave always seems it’s not the default browser while it is defined in the system settings.