"+X BAT arriving in X days" Message Doesn't Display Under Linux and Other Potential Issues with Latest Release

I use Brave across three operating systems: Linux (Fedora 34); Windows (8.1 Pro); Android (LineageOS).

Yesterday, after upgrading to the most recent version of Brave (V1.31.88) under Fedora, I noticed that the pending BAT info-bar (+X BAT arriving in X days) which displays under my Android and Windows installs, no longer displays on my Linux install of Brave. It does not display in the Rewards drop down from the address bar, nor does it display at the brave://rewards/ page.

I checked the logs at brave://rewards-internals/ and saw that - shortly after upgrading Brave yesterday - the following error shows up several times: ERROR:refill_unblinded_tokens.cc(232)] Failed to get signed tokens which led me to do some further digging.

I discovered that the wallet_status_change state under Event logs, went through the following states right after the upgrade:
PENDING ==> VERIFIED
NOT_CONNECTED ==> PENDING
VERIFIED ==> NOT_CONNECTED
NOT_CONNECTED ==> PENDING
The latter of which it seemed to be stuck on. My response was to disconnect and reconnect my Uphold account from Brave Rewards, then restart the browser.

Upon restarting Brave, I went right back to brave://rewards-internals/ where I was happy to see wallet_status_change PENDING ==> VERIFIED under Event logs.

Now, while everything else associated with Brave Rewards and Uphold appears to be in working order, I noticed yet another instance of ERROR:refill_unblinded_tokens.cc(232)] Failed to get signed tokens in Logs, and I am still not seeing the +X BAT arriving in X days message anywhere under Brave on Linux, while it is showing up under Brave on Windows and on Android. I am wondering what the implications are (e.g. Will I still be receiving last month’s rewards?), if anyone else has noticed a similar problem after upgrading the latest release, and if there’s anything else I should be looking at or doing regarding this issue.

Thanks in advance for any information!

P.S. I should note that I have been verified on Uphold for quite a while, have all three instances of Brave connected to my Uphold account, and have not encountered such issues until the most recent release.

2 Likes

Same problem here! I’m on Ubuntu 20.04 and I should receive ~2.5 BAT for October’s ads but the “+X BAT arriving in X days” did not appear. My Brave browser was auto-updated to the Oct 29th release as well.
I would expect the BATs to not have vanished into thin air.

2 Likes

That’s somewhat relieving to hear @fr_rss . Thanks for letting me know that I’m not the only one. I rarely work under Windows, so most of my rewards come from Brave under Android and Fedora. I’ve been a relatively long-term BAT holder (almost three years), so it would be a shame to lose BAT Rewards from the machine I spend the most time on. Hoping that we get some detailed feedback from the team here.

Same issue here. I’m using Arch Linux (Garuda).

1 Like

@steeven @Mattches can you give any update on this issue? Is this just a visual bug or BAT’s are actually gone.

1 Like

Hi all, thank you for reporting.Thank you for reporting! Please DM with the following information:

  • Copy/paste your Wallet ID (found on brave://rewards-internals)
  • Your OS and Brave version (first three lines in brave://version)
  • A screenshot of your Rewards panel in Settings --> Brave Rewards.

This will help to speed up the troubleshooting. Thank you in advance!

1 Like

Hello everyone.
I also have the same issue. I’m on Manjaro Linux using v1.31.88 (installed through AUR). Is this bug related to the latest version of Brave (v1.31.88)?

1 Like

Hey @steeven! Just DM’d you. Thanks for chiming in.

same problem here! i am using Ubuntu and i should recieve approx 3Bat for october ,Not the " +X BAT arriving in X days
I believe that i will get those bat as rewards of my october
@steeven
ps: brave browser has autoupdated in my system

2 Likes

hey @steeven DM’d the information listed above

2 Likes

Bats are gone no claim in linux

1 Like

why it has happened ? is anyway to get those bats?

1 Like

Hmm, now there’s a “Claim rewards” banner in brave://rewards but clicking the “Claim” button does nothing.

While I’m still seeing lots of new errors at brave://rewards-internals, I did eventually receive my rewards, so I guess all is well. I’m hoping that the errors which have been showing up in the logs since the last couple of releases are not indicative of a larger issue. Thank you to @steeven for being so communicative via PMs. It is very much appreciated.

Sadly my claim button is still unresponsive meaning no rewards can be claimed, no errors in the browser console and nothing related in Brave’s logs. Steeven seems to have helped you but he’s been making me run in circles for weeks. “Did you get the tokens? Did you update?” No actual help, NO HELP.
I am so sick and tired and defeated, I am in tears at just how little empathy I’m being shown.