Www.xda-developers.com won't load even with shields down or flash installed/enabled/disabled


#1

Heyyo, sadly on Brave Browser for the desktop even after updating to the latest version will not let me browse https://www.xda-developers.com/ without it crashing even with the shields down. :frowning:

It shows the crashed tab icon with a black background right before the page finishes loading.

I’ve also tried installing flash and enabling it in Brave Browser, rebooting the browser and trying the website again and it still crashes before finishing loading.

Steps to reproduce:

  1. Install Brave Browser
  2. Go to https://www.xda-developers.com/
  3. wait for it to almost finish loading and watch it change to black background and show the crashed tab icon.
  4. Test it on Brave Browser for Android and observe it works even with shields on
  5. Test it on other browsers (Edge, Chrome, etc) and observe the website loads fine
  6. Try with Adobe flash installed and enabled in Brave Browser and restart browser
  7. Try the website again and observe it still crashes

Hardware Specs

Operating System
Windows 10 64bit build 10563 (creators update)

CPU
Intel Core i7 3770K @ 4.20GHz 1.29v Ivy Bridge 22nm Technology
CORSAIR Hydro Series H80 (CWCH80) High Performance Liquid CPU Cooler

RAM
Kingston HyperX 16.0GB Dual-Channel DDR3 @ 2133MHz (11-12-11-30 & XMP Enabled)

Motherboard
Gigabyte Technology Co., Ltd. Z68X-UD7-B3 (Socket 1155) Bios version F11a

Graphics
ASUS VE278Q (1920x1080@60Hz via DisplayPort)
MSI R9 390 Gaming 8G

Hard Drives
960GB SanDisk Ultra II (SSD) (Windows 10, some games)
Seagate 4TB 3.5" 5900RPM Hybrid Internal Hard Drive (SSHD) (Data)
500GB Seagate ST350041 ST3500418AS SCSI Disk Device (HDD) (Linux)

hope this helps! :slight_smile:


#2

Hi @ThEMarD

Could you please update Brave and try in the latest version?

Thanks,
Lauren


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.