WSS Connection Failed in Inspect Element

I’m having an issue with connecting to an AWS LightSail instance via a browser based SSH connection. When I try to connect, it just hangs. When I look at inspect element, it throws an error stating that the WSS connection failed.


bundle_vendors.1be3c985d1be32bb5667.js:2 WebSocket connection to 'wss://' failed: 
connect @ bundle_vendors.1be3c985d1be32bb5667.js:2

I have attempted to turn Brave Shields off for the website, but it does not appear to help/work.

How can this issue be reproduced?

  1. Have a LightSail instance, click connect using SSH
  2. Opens a new tab/pop up window, attempts to connect
  3. Sits and spins forever

Expected result: The window that opens should provide a console window that works to be able to administrate the instance

Brave Version( check About Brave): V1.37.116

Additional Information: Works in other browsers, but not Brave.

Update: repeating these steps in an incognito window of Brave works and does not have the WSS error.

I have also tried to exclude the web URL(s) in the site content settings area of a normal Brave browser window and tested, no change.

Any thoughts?

May be worth disabling some of the extensions you have enabled (if any) and then testing to see if one of them are perhaps causing the issue.

cc @fanboynz

1 Like

@Mattches: sadly, that did not work. I disabled extensions one at a time and tested after each disable with a hard refresh on AWS, and no go. I did the same test with ALL extensions disabled at once, no change.

While I don’t mind using Incognito windows, it would be a ton easier to just perform the work I need to do in a normal browser window.

Any further thoughts?

A couple things — you might try clearing out the cache for AWS (lock icon in address bar, site settings --> clear data) and see if that helps. If not, can you share a screenshot of any output/errors in the dev tools console window when you try to login?

1 Like

That didn’t help, sadly. Just tried it out. :frowning:

See attached screenshot!

1 Like

a bit hard to test without a login, but does the same error show in Chrome? @dagohbah

1 Like


Try different settings for WebRTC IP handling policy in brave://settings/privacy especially the two first settings. Click on ‘learn more’ to see ip privacy concerns.

1 Like

Given the previous message “404”, maybe relogin and also check the url is okay (and is valid)

1 Like

@fanboynz Testing in Chrome works fine. Chrome still throws the first 404 error, but it works regardless. The error that’s causing all the issues is the connection failed WSS one.

@CerealLover I tried the default public and private drop down choice and it started working! What should this typically be set to, if not on default? Having said all that…I swapped it back to default instead of the other, hard refreshed the AWS page, tried to connect again, and it worked.

I guess I’m lost now as to if that actually fixed anything or not…

The 404 error remains, but WSS error is now gone.

Got it to fail again. Apparently I didn’t wait long enough - default dropdown choice breaks it, 2nd choice works.


Try google dns, (google public), flush dns and restart device.

Hey there - not sure what your last post meant. In combination with a certain drop down setting, or what? I’m sorry for not understanding.

Just checking back in on this. Any other further things we can try to get this working?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.