Won't launch on macOS Sierra version 10.12.6 after fresh install


#1

After deleting the Brave application and emptying my Trash folder (because of a prior issue), I’ve downloaded different updated versions for Mac but after installing, none will fully launch.

I most recently downloaded Brave-0.18.14, but after unzipping the file, dragging it to my “Applications” folder, clicking Brave to open it, and agreeing to let a program downloaded from the internet open, Brave doesn’t open a window. I see the Brave icon in my Dock and “Brave” appears at the top-left of my screen (where program names appear on Mac), but “File” etc. are not visible and nothing else happens. My only option is to “Quit.”

I’m not a computer expert so I haven’t run a bunch of different tests, I’ve just deleted and tried reinstalling for the last several months with the same result.

After deleting the program before trying again, I’ve tried deleting the folder located at “~/Library/Application Support/brave” per the “How to solve almost every problem after install” post, but the Terminal says no such file exists.

Thank you for your help! Let me know what other info I can provide. I haven’t tried installing the developer version.


Brave won't launch on Mac 10.12.6
#2

Hi @nickvc

Where are you downloading Brave from?

Thanks,
Lauren


#3

Hi @LaurenWags,

This link: https://www.brave.com/download/.

Best,
nickvc


#4

Thanks @nickvc

Could you try downloading it from our github repo? You’ll want the Brave-0.18.14.dmg file found here: https://github.com/brave/browser-laptop/releases/tag/v0.18.14dev

This is our latest released version and should be the same as the version at the link you provided, but just in case, this is where I get my versions from (for general use and testing) :slight_smile:

Thanks,
Lauren


#5

@LaurenWags

That worked! Thank you so much! :slight_smile:

Best,
nickvc


#6

Great, happy to hear that worked for you @nickvc!

Not sure why the other one wasn’t working for you, but we will keep an eye on that.

Thanks!
Lauren


#7