Windows 11 desktop Brave shortcut not working

Dell Inspiron 5379 2 in 1. Windows 11 21H2 (OS build 22000.1042)

After recently updating to Version 1.44.112 Chromium: 106.0.5249.119 (Official Build) (64-bit) my existing private shortcuts shortcuts failed to work. For example:

“C:\Program Files\BraveSoftware\Brave-Browser\Application\brave.exe” -incognito https://www.google.com/maps/?force=canvas

After a few unsuccessful attempts I tried run as Administrator, which was successful.
I needed to include the checkmark for run as administrator in Properties, shortcut tab to work around the issue.

Does anyone know why it is happening?

what if you type if as --incognito "https://www.google.com/maps/?force=canvas"

If not, you could always go the variables route, so you can add a variable whatever with value --incognito "https://www.google.com/maps/?force=canvas"

and you only need to add %whatever% to the end of the shortcut.
I have brave in PATH and then variables for different things I do. it works great, so it would work better in the shortcut since shortcuts only allow few characters while variables allow… more (don’t know the limit or if there is a limit).

Thanks.
The first option did the trick (with the path to brave.exe, of course). I remember testing the double-dash before writing the question but must have done something wrong.

That said, I still find it strange that my five incognito shortcuts were working until either Brave, Windows 11 or both updated (leaning towards Windows as the trigger) then they all stopped working.

Back to the editing. Thanks again.

Hello @StevieR, thank you for bringing this to our attention. The answer on this thread can be helpful to you:

Let us know if that helps. Regards.