Windows 10 settings refuses to make Brave default browser

windows
performance

#1

I have tried several (at least a half dozen) times to use Windows 10 Settings to do this, as recommended elsewhere. Each time I did this I restarted the computer as is customary with Windows machines. Failure every time. Sorry, but I’m just a ignorant peon user (technically incompetent) and don’t have time to tinker. Just wanted to let you know. I’m uninstalling this. I’ll keep the download file until someone answers promptly. I’m a good enough sport to do that.
Sorry to rain on your parade, but that’s real life.


#2

I think that it might be fixed in the next release but I am not sure :thinking: cc @clifton


#3

Yes. It should be fixed in v0.14.2. I reported this problem here:


#4

@Jacalz you are correct, sir :slight_smile: Fixed on both Windows and Ubuntu with our next release, 0.14.2!


#5

So far, so good. Which version do I have now, and when will the new version be available after testing? I’m in a bind- I haven’t been able to restore my computer to its state before installing your program- my bad for not creating a restore point. That’s what happens when I’m in a rush to try something “new and exciting”. May I have some help here?
I have tried using the backup copy of files I made the week before, but apparently that isn’t the answer. My computer now says the backup volume is larger than before: 14 GB worth. I know that’s tiny, but that’s all I really need for personal use.


#6

Go to about:brave and you will see the version number but 0.15.1 was release not long ago so it should be fixed as long as you have Brave updated :hugs: Sorry for late answer :grimacing:


#7

Thx much, and also for helping me play nice. We Scotch Irish are really, really RUDE bunch- at least my bunch is. Hope not too many feathers were ruffled. I always like seeing new versions; I’m like a kid opening Santa stuff. Hmmm… does “Santa Brave” have a nice ring? I need help expressing myself constructively, I really do.I’m also the world’s WORST keyboardist, a fact I’m not sure I should be proud of. :slight_smile:


#8

I hate to reopen an old wound but I can’t get Brave to appear as an option for default browser. (Brave 0.19.53, rev e09025b, Windows 10.0.15063 x64). It doesn’t appear as an option as initially described in the OP. This is true no matter how I try to set it: in Windows Settings, Brave Settings, by protocol in Windows Settings or Control Panel, etc. It does work when I set it by file type in Control Panel, haven’t tried by file type in Settings. (Am I right in assuming that where they overlap Control Panel and Settings are merely different views on the same data, so there’s no functional difference between them?)

Please advise. Thanks!


#9

I’ve got the same issue as phineHas56 and piz. I was hoping to use this as my new browser, but it’s just not possible to set it as default in Windows 10.

Brave 0.19.70
rev d4b94c6

I checked the registry, there is no “BraveHTML” in the path "HKEY_CURRENT_USER\SOFTWARE\Classes\BraveHTML"
I’ve rebooted already, and tried setting it through the Default Programs on the Control Panel.


#10

Working now with:

Brave 0.19.80
rev 7d07299

Thank you!


#11

I’ve been away for a while and in the meantime, the Brave browser has officially been released. The “0.x” version has been replaced by version “1.x”. Windows 10 now recognizes the Brave browser as the default on my system. I don’t know how they did it, but they did. I somehow deleted the installer from my computer so I can’t tell you exactly which version I have, but if you go to their download site I’m sure you can get the new one. Good luck! I’m going to do the same.


#12

This is how I set Brave as default on WIN10
Use [WIN]+I to bring up preferences. Scroll to browser. Set to Brave - done

Please advise if this is still an issue.


#13

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.