Windows 10 - Default browser and html viewer setting issues


#1

I am running Brave 0.22.810 on Windows 10 Home x64 and find it difficult to set Brave as my default browser and html viewer.

The Brave app don’t recognized as a listed program when I want to set default programs via Control Panel. This also happens when I want to set default programs by protocol or filetypes.

I try pointing the Brave app via C:\Users\xxx\AppData\Local\Brave while setting html filetypes to be opened by Brave but it still opened by Chrome instead.

What should I do? Thanks for any help.


#2

Hi @sabiqovsky,

Does this thread can help? How do I make Brave my default browser?
Or how about from Preferences/Settings > General > Set as default?

image


#3

No, it doesn’t work. Brave even not listed as a browser apps. This also happens when I tried to change default programs for .htm or .html filetypes.

Changing via Brave Preferences/Settings > General > Set as default also failed.

*Btw, thanks for you reply. Terima Kasih!


#4

Thanks for confirmation. cc @sriram for assistance.


#5

@sabiqovsky Do you see Brave listed when you click on Set defaults by app or Choose default applications by file type and then scroll down to .htm/.html and click on + and see if Brave is listed there?


#6

I’m having this problem as well. Here are my options:

(upload://6dAZoRAb64GmTAn6ENErTvFNNCF.JPG)


#7

not sure what happened to image.

image


#8

@Surfer @sabiqovsky could you guys run winver in run window and take a screenshot of the windows version details and share ?


Getting Windows 10 to allow Brave to be default browser
#9

Capture

UPDATE: Solved after Brave update. Thank you very much for the assistance!


#10