Windowed on opening


#1

OS: Microsoft Windows 10 Home, x64
Version: Brave 0.18.20, rev 60bb9e6

Sorry if this issue is too nitpicky for this section, I did search for it and couldn’t find any topics on it, so I hope it’s not already been mentioned.

When launching brave it always opens in windowed view, though it opens at the size it was last used, i.e. fullscreen. I know tor browser opens windowed to prevent sites from determining your resolution but perhaps it could be an option to “always open fullscreen” in the security settings, with an appropriate warning, if that is the case.

Many thanks,
himself.


#2

Hi there!

Not retaining maximized setting on Windows is a known issue and quite a popular one. We chat about it internally quite a bit and are working toward a solution.

We’re tracking it here : https://github.com/brave/browser-laptop/issues/8600

Thanks for reporting!


#3

Thanks for the quick reply!

:slight_smile:


#4

Same issue here.

I wanted to add a wrinkle to it though. At work I have two screens (laptop and monitor), and normally run Brave in the external monitor,

But at home it’s only the laptop screen. If I had Brave open at work and then open it again at home it opens on the non-existent external monitor. So I need to do Alt + Space, M and the down arrow to move it onto my laptop monitor; and then I can maximize it to my screen.