Window tiling broken in 1.67

After upgrading to version 1.67 the Brave Browser window doesn’t correctly tile anymore in KDE Plasma Desktop. Now when I try to tile the window to the left or right half of the screen, it does go to this side and adjust the size, but the window doesn’t fill to the edge of the screen. It leaves a few pixels at the top, bottom and side open where content from other windows underneath the Brave Browser window show through, which is very annoying.

Tiling has been working correctly up until at least 1.66.118 and it’s broken now in 1.67.119. The problem is NOT with KDE Plasma, that version has not changed (5.27.11) and all other windows from other applications tile correctly.

1 Like

Having same problem here, on Ubuntu 24.04 Desktop + GNOME/X11. Attached please find a screenshot that demonstrates this bug.

To reproduce:

  • Log into Ubuntu 24.04 Desktop, GNOME/X11.
  • Open two Brave windows.
  • Use Super+L and Super+R to tile the Brave windows side-by-side.

The problem also occurs when tiling windows using QuickTile, so it is likely unrelated to a specific window tiling application.

Just wanted to also confirm this is happening on Endeavor OS using KDE 6.1.0 and X11 with Brave v 1.67.119 … Brave will full screen fine, but if it is “snapped” in half or quarter screen it will have a slight buffer around the window. No other app on my distro does this, only brave.

Edit: just updated to v 1.67.123 and the problem still persists

Ok making this a new comment because I found a settings option to fix this (for me on KDE 6.1/X11)… going through the settings there is a toggle for “Use system title bar and borders” under appearance… When this is toggled on Brave will snap correctly to other apps and desktop.

Unfortunately, I do like what Brave does with the title bar but just not the floating boarders… Maybe in another update we can get these options separated out? One toggle for title bar and one toggle for borders?

EDIT: If you are using KDE… Settings-> Color & Themes-> Window Decorations->Edit button-> Window-Specific Overrides-> +Add-> Regular expression to match: .* and check Hide window title bar. Boom best of both worlds, windows snap, and no longer have the title bars.

1 Like

Has anyone found a solution for Ubuntu GNOME? I have noticed that disabling the Ubuntu tiling extensions reduces the size of the gap, but it doesn’t go away completely.

With Ubuntu tiling extension (gap set to zero):

Without Ubuntu tiling extension:


buntu tiling:

In full screen there is no gap. Also, installing various other tiling extensions increases the gap to the same size as the native tiling extension.

Also, enabling “use system title bar and borders” in the brave settings menu removes the gap. But that looks ugly and takes up more space than the gap would.

I have not found a solution to this yet. But I noticed that Chrome also has a gap now when tiling it. So maybe this issue is not specific to Brave but the bug was introduced in some upstream code that is shared between Brave and Chrome.

I think I found another hint. I was working on my system through a docking station with a triple monitor setup. For reasons that aren’t important right now i had to set my 4k monitor to 1080p for the docking station to work properly. The gap went away. I disconnected the monitors and set the laptop monitor to 1080p. No gap!
Leaving the monitor at 4k resolution but having scaling at 100% instead of 200% also works.

Are you using a 4k monitor?

Yes, I’m using a 4K monitor

The issue appears to have been fixed with yesterdays release of version 1.67.134. I can’t reproduce it on the new version, but on a manual downgrade to the previous version the gap returns.

Try updating and let me know if you still experience the issue.

Yes, I can confirm that the issue is fixed in 1.67.134 for me.