Why is Brave so aggressive with notifications, and how do you turn them off?


I hate notifications generally, I turn most off so I only see the most important ones. I really don’;t want notifications from a web browser of any kind, although some (media playback) I allow in case I do ever play something in the browser (which is rare).

I just got this notification and can find NO WAY to turn it off. It’s not listed in the possible notification types i can turn off, what does it come under and how do i stop it bothering me again? (I won’t even ask what it means as I don’t care, it’s an advert for Brave and I don’t do unwanted advertising, even if only boasting and not asking for money :slight_smile: )

You should be able to stop these from within your device’s OS settings.
Should be something like (on your device) Settings --> Apps --> Brave --> Notifications and toggle the option “off”.

That’s precisely what I did, and explained above, what option covers that type of notification? It is not made clear, correction, it is not even alluded to.
The ones I have turned on are:

completed downloads
active downloads
playing media
Other: Brave

I guess I will have to try the last one this time, and gradually decrypt the options to find the right one. Might be nicer to ensure they are all properly listed so annoyances can be turned off without all this work. Just a suggestion. thanks for responding

1 Like

I also get this problem when reinstalling Brave on Android

A blanket ‘notifications off’ seems a bit harsh as they all do different things

The browser notifications at the bottom of the list normally works for me

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.