Why does 'open in Tor' just say 'loading' forever?

I tried this for the first time with a couple of links, and that’s the response I got (nothing). Can someone please explain?

It opens for me. It does take some time to connect to Tor though… But it works for me. Could you share the links ?

I’m using it now, so I know that sometimes it works. Why sometimes and sometimes not?

not sure. Just confirming, when you open in Tor, it shows tor connected, right ?

Thanks. I don’t see “connected” anywhere. But I’m entering this in a separate instance/tor window and it’s fine, so I assume there’s nothing in the browser affecting those urls.

Do you see this when in Tor ?

I don’t remember the ‘connected successfully’. The rest seems the same.

Open a new tab and share screenshot

What do you mean “share ss”?


Wait – that was from the second instance. Back on the first one that just says ‘loading’ I see “Disconnected”. In that window I tried one of the ‘loading’ urls, and it’s still doing that. This is right click on the link in Brave and choose “Open link in private window with TOr”

And now I just pasted the url into this window and it worked. In the future I’ll look for the ‘successfully connected, open new tab and paste’ next time. Thanks for your patience. Have to go.

No problem. If possible try marking as solved.