Why do I have to choose "Keep" every time I download something?

It started a couple of months ago, but now when I download something, it doesn’t stick unless I immediately choose “Keep” instead of delete because the file type might be unsafe. I understand that some people might need that warning, so if you wanted to add the feature, that’s fine. And it’s even fine if you turn it on by default… but there needs to be a setting to turn it off. This dramatically weakened the user experience to help inexperienced users with an edge case scenario. It seems 100% contrary to the vibe and purpose of the Brave browser.

Steps to reproduce: 1. Download a file.

What happens: You have to interact with the browser just to get the file you intentionally tried to download.

Expected behavior: You click download a file, and it downloads.

When does it happen: Always without the option to customize.

Versions: macOS 10.14.6, Brave 1.5.115

Notes: Please don’t force confirmation of every basic aspect of the browsing experience for “safety.” That kind of intrusive user experience is what drove me to use Brave in the first place.

That’s weird. Can you share a screenshot of the message, @davemu?

cc @Aa-ron @mattches @steeven for assistance here since I’m not using macOS.

Absolutely, and to show how absurd it is, I got my screenshots by downloading Brave itself!

Thanks for reaching out with this. I’ve seen similar reports before and as unsatisfying as it is, many users claim that the issue seems to just “work itself out”.

I believe this is actually an issue in Chrome/Chromium that we’ve unfortunately inherited. Can you run a test for me, and try going to Menu --> Settings --> Additional Settings --> Downloads and toggle the Ask where to save each file when downloading option “on” and see if you get the same results?

1 Like

Indeed, that did fix it! I toggled it and then I was given the dialogue where to save it, which would also be an annoying extra step in downloading, but it did download without asking me to Keep/Discard. But then when I toggled it back to get rid of the “Save to” dialogue, it again did not ask about Save/Keep. So I went to another site and downloaded a different file. Still good. So that interaction fixed it. Hopefully, that helps with a solution to avoid user interaction. Thanks @Mattches


You’re very welcome – glad to hear that worked for you.