Why can't we fix the openSUSE repo permissions problem?


#1

There are complaints about this excact problem going back to 2016 now.

So TWO YEARS have passed and NO ONE can be bothered to configure the repo correctly?

For anyone with this issue, you can go into:
/etc/zypp/repos.d/repo-brave-rpm-release.repo (you will need root permissions)

Find the line:
type=rpm-md

Modify it to look like this:
type=yast2

Save and close the file. Run ‘zypper ref’ again and it will check for updates, but this change is NOT retained in the file. After you refresh your repos it will revert back to ‘rpm-md’ and you will get the same error.

This is ridiculous and the exact kind of thing which will keep people away from this browser.


#2

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.