Why can't I run speed test?


#1

Ok, so let’s start by saying that this is more of an annoyance than an urgency. But, when I try to run these two speed test sites, I get nothing. Yes, I have turned off Brave Shield on these sites, which is the only way I can even initiate the test anyway, but then when I start the test it cranks away indefinitely. What exactly is going on? Some help would be appreciated. Thank you.

FIOS: https://www.verizon.com/SpeedTest/SpeedTest.aspx?IIFlow=true

Speedtest by Ookla: http://beta.speedtest.net/


Speedtest.net does not load normally
#2

IIRC these are both Flash-based tests and we may not be detecting Flash appropriately.


#3

Speedtest (beta) by Ookla does not require Flash. It has worked until recently.


#4

So what is the solution?


#5

The speed test is lousy with tracking requests, which we block.

I just ran a quick test w/Ookla, and these are the ad/tracking requests we block:

https://preferences.truste.com/webservices/js?&domain=ziffdavis.com&type=ziffdavis&js=2
https://consent.truste.com/notice?domain=ziffdavis.com&c=teconsent&js=bb&noticeType=bb
https://d3ujids68p6xmq.cloudfront.net/x.js?cb=1508891791132
http://ad.doubleclick.net/ddm/ad/5zcx9zf5hs/2nmpc/;ord=1508891791132?

If you want to run the speed test, you can disable the shields from the lion menu, which will allow the test to run.

For some reason, Ookla has decided that the cost of their “free” speed test = user tracking and ad placement.

Hope this helps.


#6

Thank you, Luke. I appreciate the explanation. However, I had the Shield turned off all along. Also, is ad-blocking is also the issue on the FiOS page?


#7

oh wow, didn’t realize you were having the issue w/shields disabled. I’m unable to repro the issues with shields down.

I am able to test on the fios URL with shields up and all default blocking features enabled.

Would you mind entering:
about:brave

into the URL bar, and copy-pasting the info into a response here? We can see if the team can repro from the same profile info you supply. thanks!


#8

I recommend using t-online or computerbild dsl speed tests. Those are html based and very lightweight.


#9

Here you go my friend, and thank you for your effort!

Brave: 0.19.66
rev: 148f5b066d5d0d786bafaf80f396e753d42e0412
Muon: 4.5.9
libchromiumcontent: 62.0.3202.62
V8: 6.2.414.32
Node.js: 7.9.0
Update Channel: Release
OS Platform: Microsoft Windows
OS Release: 10.0.16299
OS Architecture: x64


#10

Thank you. I will give them a try. Lightweight is always good :slight_smile:


#11

Stop going to a website to run a speedtest. Download the speedtest desktop app from SpeedTest.


#12

Hi there,

The fix will be available since the 0.20.x :wink: I confirmed it ran on 0.20.5.

Thanks!


#13

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.