While reading books or comics, webpage goes blank at the end everytime

Description of the issue:
I like to read books and comics online, but the websites which provide free reading are full of ads, that’s why I use brave browser.

But while reading on iOS version of brave the webpage loads properly and suddenly goes blank right when am about to reach the end of the webpage.
It’s like an unintentional cliffhanger from brave browser, I’d not have minded if this happened once or twice, but it keeps happening at the end of every chapter like 9/10 times.

The whole page goes blank and even refreshing the tab does not work, I have to copy the url, close the current tab and open the same URL in new tab, then only it loads.

But even when I reopen the URL in new tab, I still have to catch up to the chapter and when I scroll down to the bottom, I get the same issue again.

Nothing is wrong with my internet connection and the pages are loading properly, but during that continuous scrolling the webpage just automatically goes blank. I’ve already tried with safari and there I’m able to read the content without this issue, but there are ads on every tap.

How can this issue be reproduced?

  1. Navigate to the comic website below https://mangagg.com/comic/3cm-hunter-series/chapter-71/
    2.Go to any chapter on iOS brave and keep scrolling like you are reading it.
  2. Suddenly there will only be 1 page visible and everything else would be white. (Try multiple chapters if it doesn’t happen, might be I’m extra unlucky)
  3. Even if you refresh the tab, it won’t help, you’ll need to close the current tab and open the same URL in new tab.

**Brave Version( check About Brave): 1.57

Mobile Device details iPhone 14 pro.

Additional information
Wow. After typing this whole post I tried to take a full page screenshot of the webpage as it might help, but as soon as I took the screenshot the iOS crashed and loaded like a restart and went back to lock screen.
Tried taking the screenshot on other app and other webpages (no issue). But if I take screenshot of the webpage which went blank, black loading screen appears and I’m back to iOS lock screen.

@RJ_Zoro I just tested on your link using my iPhone. I’m using iPhone 13 Pro Max using iOS 16.6.1 and Brave 1.57. I had absolutely no issue at all. The closest to an “issue” I had would be moments where the images from the page wasn’t fully loaded and was loading while scrolling. Beyond that they do have some areas where they intentionally have longer areas of white. You can see me slow down and take a look.

I had gone through various things myself and then I recorded using your link. The chapters there were loaded for the first time. I didn’t want the video to be annoyingly long, so I kind of scrolled quickly. You can see my test run at https://youtu.be/dXCH89r8avU

  • What are your Shields settings? (do you have any Content Filters active?)

  • Does this issue happen if you turn off Shields?

  • Are you connecting via wifi or mobile data?

Hi @Saoiray Thanks for looking into this issue for me.

As I’ve already told, this issue is not with the loading of the pages as I’ve tried using both wifi as well as cellular data and the pages gets loaded pretty fast compared to my scrolling speed.

I’ve recorded the issue in the video below:

As you can see the pages are getting loaded as soon as I reach them, but if you continue to watch till 37sec in the video, the whole webpage(including the top pages which got loaded earlier as well as the bottom page, except for 1 page went blank)
I covered both the top and bottom part in the video which went blank.
At 57sec in the video I tried the link for next and previous chapter on the page, but they were not responsive.
Also I tried to refresh the page after 59sec in the video. And as you can see the browser reloads, but there is no change to the webpage.

As for the content filtering, I’m using Default filtering and only 2 of those are enables as you can see in the screenshot.

@RJ_Zoro I can’t replicate regardless what changes I make. Main issue here is there’s something other than just the browser and websites taking place. I’d say try clearing cookies and/or cache, but I see you also tried in private window which should have accomplished a similar goal.

In terms of Shields settings, originally I was wondering if you might have enabled “block scripts” and that caused issues, as it would do something similar when I read things on mangahub, but even I toggled that on it didn’t load anything.

My normal settings for Shields are below:

Btw, which version of iOS are you using?

@Saoiray yes I tried in Private tab for cache issue only.
The iOS version I’m using is 16.6, just started installing 16.6.1 now.

I also tried script blocking on these manga websites, but it makes those pages unresponsive and does not load at all. So I’m not using that either.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.