Which one out of the 3 should I pick to download for linux?

Which one out of the 3 should I pick to download for linux?

For linux I see a choice between 3: release, beta, nightly
I am on Parrot linux home edition 4.11
I will also need the terminal commands e.g sudo apt etc

Thanks in advance.

Hi and welcome to the community. :slightly_smiling_face:

They should all work. It is going to be your choice what you decide to use. Of course, you can always use multiple versions! A lot of users do.

The Release version is the “… completed product, which behaves as described in the Brave privacy policy and the terms of service for Brave Rewards and other online features.” Source: Release Channel Descriptions You should read the Release Channel Descriptions document. It is really informative about the differences between the available releases.

The below information is from the Brave Browser Privacy Policy:

Nightly, Dev, and Beta browser versions

Nightly, Dev, and Beta versions of the Brave Browser are experimental previews of new Brave Browser versions. They allow us to test new features so that we can find and fix errors before releasing a new version of the Brave Browser. These test versions of the Browser may automatically send crash reports to Brave so that we can identify and fix problems. A crash report can contain personal information. See data processing details.

These incomplete versions of Brave represent unfinished and untested work on future versions of Brave, and their incomplete behaviour may not be adequately described by this policy. More information about the safety & reliability of pre-release versions of Brave can be found in our development documentation.

Including a link to installation notes: Installing Brave on Linux

I picked Release version and I got this:

sudo apt install apt-transport-https curl
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
curl is already the newest version (7.74.0-1.3+b1).
curl set to manually installed.
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
cnijfilter2 : Depends: libcupsimage2 (>= 1.4.0) but it is not going to be i
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or s
pecify a solution).

I know nothing about Linux. Sorry, someone else will have to help. However, per the Linux Installation instructions:

If you get gnutls_handshake() errors after adding the Brave repository on Debian 9, you may need to uninstall old conflicting packages.

Did you check that out?